summaryrefslogtreecommitdiff
path: root/dev-util/include-what-you-use
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-util/include-what-you-use
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-util/include-what-you-use')
-rw-r--r--dev-util/include-what-you-use/Manifest2
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-10.0.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/include-what-you-use/Manifest b/dev-util/include-what-you-use/Manifest
index 305c4dc04832..29ddabf58510 100644
--- a/dev-util/include-what-you-use/Manifest
+++ b/dev-util/include-what-you-use/Manifest
@@ -1,3 +1,5 @@
+DIST include-what-you-use-10.0.tar.gz 598644 BLAKE2B 36c81bd493edfdfdc4df31c2dcb49d5acd3f6016f706e0c9d2f031d668ca16d71797d40b04fc9dc25a21738f7075320406fd666db74a0baa3832c149fe674e0e SHA512 e54a7c7e3a6d3e0de7c263d1f26b373d95b8fab5f1f7e76f52d80341bda2bad0fb12238a325dc1e2f6d3ab5e6d8e0b4ed60b5a19dc82e06d480bcb461f9aefba
DIST include-what-you-use-9.0.src.tar.gz 589377 BLAKE2B b695354787070948d81e3e80b07bbe47a84b5609262df2220b6a62e6d648865b17e060951819f45956c6ca858977614d6e0401640509599b391a1165521b20de SHA512 f2d6ba05121a9968da9e42e8ac66f83ca0f35bfbe7cb1d616e2c6479cf2833c4668cb86e46a04ffcd5e77f10a575da9eeee5272c7609b5afad555d79cb640fb4
+EBUILD include-what-you-use-10.0.ebuild 1286 BLAKE2B 1742f6da93355f96388c2f3f22d8d5f320dd224f6b3a174672a81bc200f02836dd613e97159da3186944b0b299c3b0032281144636d83601d8fa756dca3c75ce SHA512 d93c70b87a04a10ff5e0015c39236769f6dd1c2b39e60b471840d2a2e481efeaf8fcf60808875c77735c1d2cffdf55203514afaeebbcde14e7f34af12d639e6c
EBUILD include-what-you-use-9.0.ebuild 1208 BLAKE2B 59decc2765b2d2ae78e94c153d4f879112bc07a6b42c4233837415a749bad5449c97f725c48cdaa5e5b3bc09d8142647a56f41b9ab3de5d5996a3a0150a58571 SHA512 e91cdb66656aaacd9fc094a872292ea5faad4bbd5d39a8b2ff075f0ffb4e45dbcf5fbe78ea46a9790a65504097fec81c74b6ab7a7fc4c1214a5fefddd633f746
MISC metadata.xml 357 BLAKE2B f14a0380bab03b4bb916602ed495cf9c29a4ca5839f71dca0d5f4f14eeb5fd0ddaa66dfcb15d94cbeec2a9021a9e5522ef7ae531b5b6f111b769462596da4216 SHA512 03c298d184adee1c8bd96855ba3856dbc6797f6f866397485cc10c3e02956f7bb04811a086e9cf50bbd6f996011d08ca2d272aa4b06f13ee62af5a585f67b492
diff --git a/dev-util/include-what-you-use/include-what-you-use-10.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-10.0.ebuild
new file mode 100644
index 000000000000..da2675ad0e22
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-10.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-utils flag-o-matic llvm python-single-r1
+
+# Sometimes the tag is clang_9, timetimes it's IWYU-0.13
+UPSTREAM_PV=0.14
+
+DESCRIPTION="Find unused include directives in C/C++ programs"
+HOMEPAGE="https://include-what-you-use.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LLVM_MAX_SLOT=10
+
+RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAX_SLOT}
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}-${UPSTREAM_PV}
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Note [llvm install path]
+ # Unfortunately all binaries using clang driver
+ # have to reside at the same path depth as
+ # 'clang' binary itself. See bug #625972
+ # Thus as a hack we install it to the same directory
+ # as llvm/clang itself.
+ -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${EPYTHON}" run_iwyu_tests.py
+}