summaryrefslogtreecommitdiff
path: root/dev-util/include-what-you-use
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-util/include-what-you-use
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-util/include-what-you-use')
-rw-r--r--dev-util/include-what-you-use/Manifest2
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-12.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/include-what-you-use/Manifest b/dev-util/include-what-you-use/Manifest
index 5ba385a6ab72..c94672e7c507 100644
--- a/dev-util/include-what-you-use/Manifest
+++ b/dev-util/include-what-you-use/Manifest
@@ -1,3 +1,5 @@
DIST include-what-you-use-11.0.tar.gz 603435 BLAKE2B 7bfa37349cc4bf5d07033c28d9d3851f0ce2093f1703a0392ac633ab2761dfdfb7cd923099177747e3389d2d41330351242c6f936399acf73119c201d8776978 SHA512 db15efa9b92015322e9a188be6cf16a5c6fd71271c94fde45245676f2a8f6ffe4c7837e3b0bb5f9be6cbe78aab245129816a3b046c44c261a2b7ab5c3a9ea7b9
+DIST include-what-you-use-12.0.tar.gz 742573 BLAKE2B b8cd90db490d13f140126df8955d0968a9248480da09ca29b82fe1178c779ca75e6f29239bc6fb1556200c7d7c498f2340839e8500455ecaed9e6199fd3d55f7 SHA512 2923e18c40ddc5c03458b896d991adde03d489c6645ecc3cc4f69a508e323534afdef3233943e99533ffc21c64a10a8a5c635dc4797a61edf09d0a7a918a3cd5
EBUILD include-what-you-use-11.0-r1.ebuild 1308 BLAKE2B bbc6ca260522f5cacd844c509c41e104eea86a97ccf65c9ff61a1a64a63b106c75cda0b9c61b12b95cd0abd63f50d32789b06ede0e8024ee9b08e9ba607f77db SHA512 29e627efe52e28b9fb1aa4dc3ef65fb49d7abf546f1d3953d1d931015568b4c65c1bcb8e7250b01d6ab32a746dc83fc87840396831b0a2179577652d0102526e
+EBUILD include-what-you-use-12.0.ebuild 1308 BLAKE2B dbafe04ed482d17721ac590a324cea24cf601de45af8af3cda3d744f58febd914b3b5cf2b48122002191e6c6bae34a1daa2ffe8bbd3d79d4fdb6d63d7f922dea SHA512 edeff418ef2284a6a60aea486926ac53c37059cb66a2a022f7d06266ef38ac76bfa8e5b94cc562013bf3df88cb0caf75b5d41bd8a0430d0d498f03e14233d08c
MISC metadata.xml 357 BLAKE2B f14a0380bab03b4bb916602ed495cf9c29a4ca5839f71dca0d5f4f14eeb5fd0ddaa66dfcb15d94cbeec2a9021a9e5522ef7ae531b5b6f111b769462596da4216 SHA512 03c298d184adee1c8bd96855ba3856dbc6797f6f866397485cc10c3e02956f7bb04811a086e9cf50bbd6f996011d08ca2d272aa4b06f13ee62af5a585f67b492
diff --git a/dev-util/include-what-you-use/include-what-you-use-12.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-12.0.ebuild
new file mode 100644
index 000000000000..ecd93d6af5f9
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-12.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit cmake flag-o-matic llvm python-single-r1
+
+# Sometimes the tag is clang_9, sometimes it's IWYU-0.13
+UPSTREAM_PV=0.16
+
+DESCRIPTION="Find unused include directives in C/C++ programs"
+HOMEPAGE="https://include-what-you-use.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LLVM_MAX_SLOT=12
+
+RDEPEND="
+ sys-devel/clang:${LLVM_MAX_SLOT}=
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}-${UPSTREAM_PV}
+
+llvm_check_deps() {
+ has_version "sys-devel/clang:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Note [llvm install path]
+ # Unfortunately all binaries using clang driver
+ # have to reside at the same path depth as
+ # 'clang' binary itself. See bug #625972
+ # Thus as a hack we install it to the same directory
+ # as llvm/clang itself.
+ -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ "${EPYTHON}" run_iwyu_tests.py
+}