summaryrefslogtreecommitdiff
path: root/dev-util/include-what-you-use
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-14 02:02:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-14 02:02:08 +0000
commit59d772d9463f8cf6a145a677bedbf377a0625aff (patch)
tree5a0e382968fd656a056c886e36cfb4491535b489 /dev-util/include-what-you-use
parent2a3e0d61b3d88306b6fae46756f9ba7d230222ae (diff)
gentoo auto-resync : 14:12:2024 - 02:02:07
Diffstat (limited to 'dev-util/include-what-you-use')
-rw-r--r--dev-util/include-what-you-use/Manifest3
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-0.23-r1.ebuild63
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-0.23.ebuild4
3 files changed, 65 insertions, 5 deletions
diff --git a/dev-util/include-what-you-use/Manifest b/dev-util/include-what-you-use/Manifest
index 6bb1fb4f038c..29d529429ac6 100644
--- a/dev-util/include-what-you-use/Manifest
+++ b/dev-util/include-what-you-use/Manifest
@@ -3,5 +3,6 @@ DIST include-what-you-use-0.22.tar.gz 796681 BLAKE2B 6ae0b2fd94367c458f2db268493
DIST include-what-you-use-0.23.tar.gz 813726 BLAKE2B 845101985d1c39925605d2908ad76c40b8df0838467d7afd83b644914893f8e32ed1563348e568bc126ea4349ab390b189b734f66cf3b8da75277af169313a23 SHA512 5c2bbda7dbc614089717d2a4f8b9a96111dc30efcdd331a21c548399d58b47229210d5f17eb48eeb56c44797068ebac634a5d68a5c50ff322753e5f7965b3d48
EBUILD include-what-you-use-0.21.ebuild 2060 BLAKE2B 7b2cbf43a176e8fdb8da30539e6f6c580b4068378e59ef6c2ab6fcf951d8640afcf99af6072636dea11169cf4739f42a5f88af9ff958bcdd8bb51d3d4eb80a1c SHA512 ccb0f0b1f039f362f391fd65eec84406e7a73ba13b882de1e36443f1d56b0d128f7dd12adbb1339a305f04086eb9b75b567a31e71930cbf623e722f7d714c607
EBUILD include-what-you-use-0.22.ebuild 2060 BLAKE2B b78f1005c46ad3b2069f847190de4797481b4a686b588878a54654f2b08ab431022f1da0f3f554738668494cce50eeed2edeacac96f9b54acb2ea7ec7cf03764 SHA512 c56f78dfe7c0f257b7c2cf7ebf6891783e896be92341ea2df8a79be19d6d2542febb00b00b783e9c7a96113109f31ba4a939e81aca490c666d20d605208963ea
-EBUILD include-what-you-use-0.23.ebuild 2090 BLAKE2B b34c63ab970730edc7246e85a09d6ae83d58f4bde0bca23febcb64162b6d10694bf45a9d3d6f31fff24122f64278d01ec13db2fa163a382ede108c7f862c65ba SHA512 7290078a9c954ef340fe2f0b3f5a047e1baa217c373c94172c6d043fe0854530f4da65cecb1b5b839bc649a218ed17edd1b85ffe7f9fe3943335910712088a64
+EBUILD include-what-you-use-0.23-r1.ebuild 1451 BLAKE2B 36412430e8d41c73f928277b8d8a4ee392ec07aded533259603059f1c68812ef492d8aadacad7f9cc8e0976fb4f346115187ec31b127a3367fc33d7c781a0dc7 SHA512 ad7b28bb37e59a92d08191d96b602f3690876e9925c084e0c040ddb9ab5ced11e9fc0694b907a5eb7633afd90efa07ac487cc6de7e0748772df74b2f09ca8410
+EBUILD include-what-you-use-0.23.ebuild 2023 BLAKE2B 577b28c1d896ecda9713a9139e837e87060ac2967a6d0db0780528238a4dbceec8d35aa856e84bf1c80e6afc73e0ef4f308e5b1e4d4d0796bbeb13d3e5c04a10 SHA512 66ede734cb1c371a8ba30fc816344a78459dea970712f3fc45d243c875edf01d871a55433cb96b1544466393c32c291718ef0fd373296163012dae372dd02bb1
MISC metadata.xml 353 BLAKE2B 2d95f026ce60294177b001cddd8904988aeddb3fb257a73bcf1d028bebd747b0b9467322a0fb87a5de1f7074721ebc2b9931eaa1c519fcef0388a61a8924fea9 SHA512 88e999a1bb1d9993d150347db7b1ec340978594cd2543191646e54d8fb5e125a68063916f048cc1a7166ccd646d66ea33f7f37d94ff20ed21abc7b7c8413e222
diff --git a/dev-util/include-what-you-use/include-what-you-use-0.23-r1.ebuild b/dev-util/include-what-you-use/include-what-you-use-0.23-r1.ebuild
new file mode 100644
index 000000000000..8b90092ee700
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-0.23-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+LLVM_COMPAT=( 19 )
+
+inherit cmake llvm-r1 python-single-r1
+
+DESCRIPTION="Find unused include directives in C/C++ programs"
+HOMEPAGE="https://include-what-you-use.org/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ $(llvm_gen_dep '
+ llvm-core/clang:${LLVM_SLOT}=
+ llvm-core/llvm:${LLVM_SLOT}=
+ ')
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ llvm-r1_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # Note [llvm install path]
+ # Unfortunately all binaries using clang driver
+ # have to reside at the same path depth as
+ # 'clang' binary itself. See bug #625972
+ # Thus as a hack we install it to the same directory
+ # as llvm/clang itself.
+ -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix)"
+ # Relative path to the clang library
+ # https://github.com/include-what-you-use/include-what-you-use/commit/e046d23571876e72719ef96a36ff0cb1cb2e64b6
+ -DIWYU_RESOURCE_DIR="../../../clang/${LLVM_SLOT}"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ "${EPYTHON}" run_iwyu_tests.py \
+ -- "${BUILD_DIR}"/bin/${PN} \
+ || die "Tests failed with $? (using ${EPYTHON})"
+}
diff --git a/dev-util/include-what-you-use/include-what-you-use-0.23.ebuild b/dev-util/include-what-you-use/include-what-you-use-0.23.ebuild
index 85401442c5d1..b7e3a9e1a4ff 100644
--- a/dev-util/include-what-you-use/include-what-you-use-0.23.ebuild
+++ b/dev-util/include-what-you-use/include-what-you-use-0.23.ebuild
@@ -30,10 +30,6 @@ DEPEND="${RDEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-llvm_check_deps() {
- has_version "llvm-core/clang:${LLVM_SLOT}"
-}
-
pkg_setup() {
llvm-r1_pkg_setup
python-single-r1_pkg_setup