summaryrefslogtreecommitdiff
path: root/dev-util/imediff2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-util/imediff2
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/imediff2')
-rw-r--r--dev-util/imediff2/Manifest4
-rw-r--r--dev-util/imediff2/files/1.1.2-python-3.patch68
-rw-r--r--dev-util/imediff2/imediff2-1.1.2-r5.ebuild (renamed from dev-util/imediff2/imediff2-1.1.2-r4.ebuild)0
3 files changed, 57 insertions, 15 deletions
diff --git a/dev-util/imediff2/Manifest b/dev-util/imediff2/Manifest
index b17abe1da051..3a4b6e3e07f7 100644
--- a/dev-util/imediff2/Manifest
+++ b/dev-util/imediff2/Manifest
@@ -1,4 +1,4 @@
-AUX 1.1.2-python-3.patch 3102 BLAKE2B cae5f4633e43cd6c9ee94422070d556bc1419eabf702033017d3366c618cbd88d8afcde2d68fb19dc9328170b226fe509331f6cca595c2d8d1657c6dd05c3a75 SHA512 847998b733587ff3714c9a2b482a461a29de99d836c0ad4ba5e27fdf4f53deb534369146b6ccf454ec362903058d74e8af0b3c4d660ddf59d2d769e93b6de6dd
+AUX 1.1.2-python-3.patch 4553 BLAKE2B bc16393f3c7071017255e8f188456e77d89a2ab2d605d6d99882aef4c65c7e5270a9348cf278a98d5ff7527423e899feffbb93b00f12a8c6e9a7b131acb86eba SHA512 fa5065572eb7fdbf38e3d7785ae92bddaeae8eadd9dbd006f5691c8647087df7529015750b66ea7618dd3306fcda80083c8dc2d2f019787137095db5b2c1a4d7
DIST imediff2_1.1.2.orig.tar.gz 17974 BLAKE2B f83b6ab652b1dd044587e75e4e7551a8132e1860b14f0d85d37f35383bd161a672860162e93554cf4db844d6a4700fa1876a30874c50fcb8442b4190a9b19185 SHA512 54d196d67107283bc3339eba30acb1c60972f256a268e86da397e0bdafa05220facc7979638a6a917b0c2dc7171edc3aa6b188295c9f40e9debf87a63731e748
-EBUILD imediff2-1.1.2-r4.ebuild 814 BLAKE2B 95c325c3a197088b415fa739553a7e0be0fd60389f4f0e2b3af82caa097adfdd3b4e751b5393282cdf2422353463d546a6d6623fe165175c9f39ab73a952afa3 SHA512 6cd0c1a6014f058ed575f5492c593b97b2472294b71e558a210601f293172a1d5a323b6b9917d93a7504d668c57a568d02454f9dee6e01cdff465026c5b7b819
+EBUILD imediff2-1.1.2-r5.ebuild 814 BLAKE2B 95c325c3a197088b415fa739553a7e0be0fd60389f4f0e2b3af82caa097adfdd3b4e751b5393282cdf2422353463d546a6d6623fe165175c9f39ab73a952afa3 SHA512 6cd0c1a6014f058ed575f5492c593b97b2472294b71e558a210601f293172a1d5a323b6b9917d93a7504d668c57a568d02454f9dee6e01cdff465026c5b7b819
MISC metadata.xml 357 BLAKE2B fd7b99a53b06a9ed310039486dd9c631d70ae5af05b47b42009e92b6134e52ee13e520066b8170f70b000a8eca1ca6c3c670478e393a4e36f3fe6c21187f090e SHA512 2c36e9355ac79bb027b25c63e0487299cfdf226217ea891349c4665107f6e7fb2931e56386ff1d88f16ad9e573041fc94658f61e8658d234b04bfa49c5fe902b
diff --git a/dev-util/imediff2/files/1.1.2-python-3.patch b/dev-util/imediff2/files/1.1.2-python-3.patch
index a7b4fadf4d66..811f41583129 100644
--- a/dev-util/imediff2/files/1.1.2-python-3.patch
+++ b/dev-util/imediff2/files/1.1.2-python-3.patch
@@ -1,6 +1,6 @@
--- a/imediff2 2017-11-14 09:28:57.007929569 -0500
+++ b/imediff2 2017-11-14 10:11:12.618496692 -0500
-@@ -18,10 +18,12 @@
+@@ -18,20 +18,20 @@
# License along with the program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
@@ -15,7 +15,9 @@
import curses
import tempfile
import gettext
-@@ -31,7 +33,6 @@
+ import difflib
+ import getopt
+-import string
import types
import time
import pty
@@ -35,11 +37,11 @@
- except IOError, (error, message):
- if error == errno.ENOENT and assume_empty:
+ except IOError as e:
-+ if e.error == errno.ENOENT and assume_empty:
++ if e.errno == errno.ENOENT and assume_empty:
return ""
else:
- sys.stderr.write(_("Could not read '%s': %s\n") % (filename, message))
-+ sys.stderr.write(_("Could not read '%s': %s\n") % (filename, e.message))
++ sys.stderr.write(_("Could not read '%s': %s\n") % (filename, e.strerror))
sys.exit(3)
def strip_end_lines( txt ):
@@ -57,6 +59,27 @@
decor, color_pair] )
j+=1
+@@ -287,9 +287,9 @@
+ def sel_next( dir ):
+ global sel, active_chunks
+ if dir == 'up':
+- rng = range(sel-1, -1, -1)
++ rng = list(range(sel-1, -1, -1))
+ else:
+- rng = range(sel+1, len(active_chunks))
++ rng = list(range(sel+1, len(active_chunks)))
+ for j in rng:
+ if active_chunks[j][1] > y and active_chunks[j][0] < y+winh:
+ sel = j
+@@ -442,7 +441,7 @@
+ elif c == ord('h') or c == ord('?') or c == curses.KEY_HELP:
+ helpw = 0
+ helph = 0
+- for l in string.split(helptext(), "%c"%10):
++ for l in helptext().split("%c"%10):
+ helpw = max(helpw, len(l))
+ helph += 1
+ helppad = curses.newpad(helph+2, helpw+2)
@@ -512,21 +513,21 @@
try:
opts, args = getopt.getopt(sys.argv[1:], "hmuo:abcNV",
@@ -65,26 +88,44 @@
- print _("Error: ") + str(e)
- print usagetext()
+except getopt.GetoptError as e:
-+ print(_("Error: ") + str(e))
-+ print(usagetext())
++ print((_("Error: ") + str(e)))
++ print((usagetext()))
sys.exit(2)
for o, a in opts:
if o in ("-h", "--help"):
- print usagetext()
-+ print(usagetext())
++ print((usagetext()))
sys.exit()
elif o in ("-V", "--version"):
- print "%s %s" % (PACKAGE, VERSION)
-+ print("%s %s" % (PACKAGE, VERSION))
++ print(("%s %s" % (PACKAGE, VERSION)))
sys.exit()
if len(args)<2:
- print usagetext()
-+ print(usagetext())
++ print((usagetext()))
sys.exit(2)
for o, a in opts:
+@@ -592,15 +592,15 @@
+ if launch_editor:
+ assert( not editor is None )
+ try:
+ (of, of_name) = tempfile.mkstemp(prefix='imediff2')
+- os.write( of, output )
++ os.write( of, output.encode() )
+ os.close(of)
+ time.sleep(0.1) # make the change visible - many editor look a lot like imediff2
+ editor_ret = os.system('%s %s' % (editor, of_name))
+ time.sleep(0.1)
+ if editor_ret == 0:
+ new_b_lines = read_lines(of_name)
+- if string.join(new_b_lines, '') == output:
++ if ''.join(new_b_lines) == output:
+ chunk_mode = 'old'
+ elif new_b_lines != lines_a:
+ lines_b = new_b_lines
@@ -607,8 +608,8 @@
else:
chunks = 'old'
@@ -92,7 +133,7 @@
- except IOError, (error, message):
- sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, message));
+ except IOError as e:
-+ sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, e.message));
++ sys.stderr.write(_("Could not write to '%s': %s\n") % (of_name, e.strerror));
if not launch_editor:
break
@@ -101,13 +142,14 @@
try:
if ofile is not None:
- of = file(ofile, 'wb')
-+ of = open(ofile, 'w')
- of.write( output )
++ of = open(ofile, 'wb')
+- of.write( output )
++ of.write( output.encode() )
of.close()
sys.exit(0)
- except IOError, (error, message):
- sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, message));
+ except IOError as e:
-+ sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, e.message));
++ sys.stderr.write(_("Could not write to '%s': %s\n") % (ofile, e.strerror));
sys.exit(3)
diff --git a/dev-util/imediff2/imediff2-1.1.2-r4.ebuild b/dev-util/imediff2/imediff2-1.1.2-r5.ebuild
index 22d3fb364d12..22d3fb364d12 100644
--- a/dev-util/imediff2/imediff2-1.1.2-r4.ebuild
+++ b/dev-util/imediff2/imediff2-1.1.2-r5.ebuild