summaryrefslogtreecommitdiff
path: root/dev-util/idea-community
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-03 02:07:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-03 02:07:18 +0000
commit7f4b508a2da3c371c7e770aa6ab83b0c4237cd1c (patch)
tree81d78cbf05f5daa7d57418d32f44b0149a56a765 /dev-util/idea-community
parentd4f65848c7ecabb56e2f93889cbd20078cd347f7 (diff)
gentoo auto-resync : 03:12:2024 - 02:07:18
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest3
-rw-r--r--dev-util/idea-community/idea-community-2024.3-r1.ebuild180
-rw-r--r--dev-util/idea-community/metadata.xml3
3 files changed, 185 insertions, 1 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index 1205f993f6ce..59bc9e148bb2 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,4 +1,5 @@
DIST idea-community-2024.3-aarch64.tar.gz 924922319 BLAKE2B f83fe4ff6a38a5bc4f76072626052d78a27782dd955984e2a9484fb969a22b2449d7da4293ca97845943ff7dde8caf312f3d75510cee8b499a7722bc1047d193 SHA512 e3156a00b8765344ea5c244870ade21e96a55856027b0d5f1467193b487672fdb6842d62f5e453b1590866bf2a5e161623aa389fb31a8e1464e82c80b92eb8fc
DIST idea-community-2024.3-amd64.tar.gz 924886996 BLAKE2B ae5b7f5a50482df75ff72527d6a76a7453ee9319661aa4f9516ea07781ef4687c15ac00b65614bb7d752ff0ca923eaa3a84027589eeaf18cde41c443f60fb1a4 SHA512 f0c4251fd736b513d69b129470df4d7a2dd7b90c7a73c9fa975800e1e07336860a13353f97341300bf1286ffc0e8524399103bc757e1d18699dbdacf258dc5e8
+EBUILD idea-community-2024.3-r1.ebuild 5107 BLAKE2B 8eeda4365f0877534ff98820d8bfd5a17c4fa5ad0171e1c77c736e64a5b5ea84465d5848f408f3c4b0650ef2bca549238104b0460c8c13ffb4ab35007561c672 SHA512 482335d51aca7905a70e0fc583a3d7b92ff621710e9b59c599d5ade40f7533d8d3bda5962fbf3575200a6a0ecd6f356a93290fd96e096095114a7c88dfeb7015
EBUILD idea-community-2024.3.ebuild 4732 BLAKE2B f13f27bea0a7538a5cd77dc3833653704cab30652c7e786e7e811a427c3260453db49122ba122ee6d6177cc8cc0e343da4fd4711fa3ece53c4a9aced5836d2a4 SHA512 89cd63096f50507a63b05f7929ac7cb848eaf57d1f3ffa296d2ba2823450a4f7d458ee9f211c3bd5438c96c53ab04168f1b9dfefc4457035558fa23cee35b9d8
-MISC metadata.xml 454 BLAKE2B 297cfd8c543bf216cd45b66b5284f310659422e91f12af3d0bbe2ff689d94c96988d4c125c75a95526135b2c0f54a004ee43e1c1c4dfe4d1d68e86af5f75ab0d SHA512 5ca382bcbc51ea5400cbaeb067bccfcb4a245e208a2769d800cbd80fc7151310f895d410e5828c9a32223ab93345716ba4a2ebce521092631a4b7c0858519ef2
+MISC metadata.xml 537 BLAKE2B 1b41a4099c46288757f1001d30171363df1a5536c5b3bcfc3cb2610e2c2b8b907a13abd969a3f711e4579a572414c881a97b3818bbe20b280084497ebbeb8c2d SHA512 0cf8c9625044d20e2d274a66c0c22785776b4b01cff484c9b32d6bb2d36db0c629413330fef8abeaf2530d079ae6c7da7c32ec8c597f8f39f9136719c22e27e5
diff --git a/dev-util/idea-community/idea-community-2024.3-r1.ebuild b/dev-util/idea-community/idea-community-2024.3-r1.ebuild
new file mode 100644
index 000000000000..c03b88647d02
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2024.3-r1.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop wrapper
+
+MY_PV=$(ver_cut 1-2)
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+SRC_URI="
+ amd64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}-aarch64.tar.gz -> ${P}-aarch64.tar.gz )
+ "
+
+S="${WORKDIR}/idea-IC-${PV}"
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
+ GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL-1.1 ZLIB"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="experimental wayland"
+REQUIRED_USE="experimental? ( wayland )"
+
+DEPEND="
+ || (
+ >=dev-java/openjdk-17.0.8.1_p1:17
+ >=dev-java/openjdk-bin-17.0.8.1_p1:17
+ )"
+
+RDEPEND="${DEPEND}
+ sys-libs/glibc
+ media-libs/harfbuzz
+ dev-java/jansi-native
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXrender
+ media-libs/freetype
+ x11-libs/libXext
+ dev-libs/wayland
+ x11-libs/libXi
+ x11-libs/libXtst
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXrandr
+ media-libs/alsa-lib
+ app-accessibility/at-spi2-core
+ x11-libs/cairo
+ net-print/cups
+ x11-libs/libdrm
+ media-libs/mesa
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/libdbusmenu
+ x11-libs/libxkbcommon
+ x11-libs/libXcursor
+ x11-libs/pango"
+
+QA_PREBUILT="opt/${PN}/*"
+
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+
+src_unpack() {
+
+ default_src_unpack
+ if [ ! -d "$S" ]; then
+ einfo "Renaming source directory to predictable name..."
+ mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
+ fi
+}
+
+src_prepare() {
+
+ default_src_prepare
+
+ if use amd64; then
+ JRE_DIR=jre64
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
+ else
+ JRE_DIR=jre
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-x86-64/libquiche.so
+ fi
+
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+
+ # rm LLDBFrontEnd after licensing questions with Gentoo License Team
+ rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+ rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ patchelf --set-rpath '$ORIGIN' "jbr/lib/libjcef.so" || die
+ patchelf --set-rpath '$ORIGIN' "jbr/lib/libcef.so" || die
+ patchelf --set-rpath '$ORIGIN' "jbr/lib/jcef_helper" || die
+
+ if ! use elibc_musl; then
+ rm plugins/platform-ijent-impl/ijent-aarch64-unknown-linux-musl-release
+ fi
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ local dst="${D}${dir}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea,idea.sh,inspect.sh,restarter,fsnotifier}
+
+ if [[ -d jbr ]]; then
+ fperms 755 "${dir}"/jbr/bin/{java,javac,javadoc,jcmd,jdb,jfr,jhsdb,jinfo,jmap,jps,jrunscript,jstack,jstat,jwebserver,keytool,rmiregistry,serialver}
+
+ # Fix #763582
+ fperms 755 "${dir}"/jbr/lib/{chrome-sandbox,jcef_helper,jexec,jspawnhelper}
+ fi
+
+ if use amd64; then
+ JRE_DIR=jre
+ JRE_DIR=jre
+ fi
+
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+
+ # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
+ local bundled_script_name="${PN%-*}.sh"
+ make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
+
+ local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
+ newicon $pngfile "${PN}.png" || die "we died"
+
+ if use experimental; then
+ make_desktop_entry "/opt/idea-community/bin/idea -Dawt.toolkit.name=WLToolkit"
+ "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
+
+ ewarn "You have enabled the experimental USE flag."
+ ewarn "This is a Wayland support preview. Expect instability."
+ else
+ make_desktop_entry "/opt/idea-community/bin/idea"
+ "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
+ fi
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+
+ # remove bundled harfbuzz
+ rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
+}
diff --git a/dev-util/idea-community/metadata.xml b/dev-util/idea-community/metadata.xml
index bff8e8630cd1..927a62d51e4e 100644
--- a/dev-util/idea-community/metadata.xml
+++ b/dev-util/idea-community/metadata.xml
@@ -5,6 +5,9 @@
<email>mpagano@gentoo.org</email>
<name>Mike Pagano</name>
</maintainer>
+ <use>
+ <flag name="experimental">Enables Wayland support preview.</flag>
+ </use>
<longdescription lang="en">
Excel at enterprise, mobile and web development with Java, Scala and Groovy, with all the latest modern technologies and frameworks available out of the box.
</longdescription>