summaryrefslogtreecommitdiff
path: root/dev-util/hxtools/hxtools-20201116.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-util/hxtools/hxtools-20201116.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-util/hxtools/hxtools-20201116.ebuild')
-rw-r--r--dev-util/hxtools/hxtools-20201116.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/hxtools/hxtools-20201116.ebuild b/dev-util/hxtools/hxtools-20201116.ebuild
new file mode 100644
index 000000000000..10d8f9635463
--- /dev/null
+++ b/dev-util/hxtools/hxtools-20201116.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A collection of tools and scripts"
+HOMEPAGE="https://inai.de/projects/hxtools/"
+SRC_URI="https://inai.de/files/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=sys-apps/pciutils-3
+ >=sys-apps/util-linux-2.19
+ >=sys-libs/libhx-3.12.1:=
+ dev-lang/perl
+ sys-libs/libcap:=
+ x11-libs/libxcb:0=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+
+ # man2html is provided by man
+ rm -r "${ED}"/usr/bin/man2html || die
+ rm -r "${ED}"/usr/share/man/man1/man2html* || die
+
+ # Don't collide with dev-util/cwdiff
+ mv "${ED}"/usr/bin/cwdiff "${ED}"/usr/bin/cwdiff.hx || die
+ mv "${ED}"/usr/share/man/man1/cwdiff.1 "${ED}"/usr/share/man/man1/cwdiff.hx.1 || die
+
+ # Gentoo doesn't have /usr/share/kbd:
+ mv "${ED}"/usr/share/kbd/* "${ED}"/usr/share/ || die
+ gzip "${ED}"/usr/share/consolefonts/*fnt || die
+}