summaryrefslogtreecommitdiff
path: root/dev-util/howdoi/howdoi-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-util/howdoi/howdoi-1.2.1.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-util/howdoi/howdoi-1.2.1.ebuild')
-rw-r--r--dev-util/howdoi/howdoi-1.2.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/howdoi/howdoi-1.2.1.ebuild b/dev-util/howdoi/howdoi-1.2.1.ebuild
new file mode 100644
index 000000000000..e97bb424dc85
--- /dev/null
+++ b/dev-util/howdoi/howdoi-1.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A code search tool"
+HOMEPAGE="https://pypi.org/project/howdoi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cachelib[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyquery-1.4.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"