summaryrefslogtreecommitdiff
path: root/dev-util/hfstospell/hfstospell-0.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-util/hfstospell/hfstospell-0.5.2-r1.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-util/hfstospell/hfstospell-0.5.2-r1.ebuild')
-rw-r--r--dev-util/hfstospell/hfstospell-0.5.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/hfstospell/hfstospell-0.5.2-r1.ebuild b/dev-util/hfstospell/hfstospell-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..3b6cb8750ad9
--- /dev/null
+++ b/dev-util/hfstospell/hfstospell-0.5.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="HFST spell checker library and command line tool"
+HOMEPAGE="https://github.com/hfst/hfst-ospell"
+SRC_URI="https://github.com/hfst/hfst-ospell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clang"
+
+DEPEND="app-arch/libarchive
+ dev-libs/icu:=
+ !clang? (
+ dev-cpp/libxmlpp:2.6
+ dev-libs/tinyxml2
+ )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/hfst-ospell-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # https://github.com/hfst/hfst-ospell/issues/48
+ if tc-is-clang; then
+ econf --without-libxmlpp --without-tinyxml2
+ else
+ default
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete -o -name '*.a' -delete || die
+}