summaryrefslogtreecommitdiff
path: root/dev-util/hfstospell/hfstospell-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
commitd00821e77f72d4af4ea30158c1c6e18ffff0875b (patch)
treeb28b6cb077ae6b2457e30d49028fc978d8e2b59b /dev-util/hfstospell/hfstospell-0.5.1.ebuild
parent36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (diff)
parent6a339b4f9ec107438bb71a6f9ca72fd42fbfd436 (diff)
Merge branch 'next'
Diffstat (limited to 'dev-util/hfstospell/hfstospell-0.5.1.ebuild')
-rw-r--r--dev-util/hfstospell/hfstospell-0.5.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/hfstospell/hfstospell-0.5.1.ebuild b/dev-util/hfstospell/hfstospell-0.5.1.ebuild
new file mode 100644
index 000000000000..7aac0223c0d7
--- /dev/null
+++ b/dev-util/hfstospell/hfstospell-0.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="HFST spell checker library and command line tool"
+HOMEPAGE="https://github.com/hfst/hfst-ospell"
+SRC_URI="https://github.com/hfst/hfst-ospell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/libarchive
+ dev-cpp/libxmlpp:2.6
+ dev-libs/icu:=
+ dev-libs/tinyxml2"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/hfst-ospell-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}