summaryrefslogtreecommitdiff
path: root/dev-util/hfstospell/hfstospell-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
commita1392efe64137262023d92492396ca9156d22396 (patch)
treede438b2711c7697c4597fb04f07e988586f34233 /dev-util/hfstospell/hfstospell-0.5.1.ebuild
parente3cf2c86fca1750343c1885311f857f185ee4f2d (diff)
gentoo resync : 13.09.2019
Diffstat (limited to 'dev-util/hfstospell/hfstospell-0.5.1.ebuild')
-rw-r--r--dev-util/hfstospell/hfstospell-0.5.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/hfstospell/hfstospell-0.5.1.ebuild b/dev-util/hfstospell/hfstospell-0.5.1.ebuild
new file mode 100644
index 000000000000..7aac0223c0d7
--- /dev/null
+++ b/dev-util/hfstospell/hfstospell-0.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="HFST spell checker library and command line tool"
+HOMEPAGE="https://github.com/hfst/hfst-ospell"
+SRC_URI="https://github.com/hfst/hfst-ospell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/libarchive
+ dev-cpp/libxmlpp:2.6
+ dev-libs/icu:=
+ dev-libs/tinyxml2"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/hfst-ospell-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}