summaryrefslogtreecommitdiff
path: root/dev-util/heaptrack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-util/heaptrack
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-util/heaptrack')
-rw-r--r--dev-util/heaptrack/Manifest2
-rw-r--r--dev-util/heaptrack/heaptrack-9999.ebuild31
2 files changed, 19 insertions, 14 deletions
diff --git a/dev-util/heaptrack/Manifest b/dev-util/heaptrack/Manifest
index d58e7090e6c6..0fff0803ff64 100644
--- a/dev-util/heaptrack/Manifest
+++ b/dev-util/heaptrack/Manifest
@@ -1,2 +1,2 @@
-EBUILD heaptrack-9999.ebuild 1295 BLAKE2B 700d336e4bf13b2149d6a919d847632a4e2e9981ea40d0cc2c271223ecd7b888f1df7df26a09f42d6582a97a8d69346b699f737016c392fe20dd77dadf1f328e SHA512 1ee5c61bd545dfdbb9a98063e7c31d4a59366175d36386b1fc2e84526e421ca8ad792662eac3b0fa70d7f8d5ff759392ff14fab5753ee6bfe342f50593e64a09
+EBUILD heaptrack-9999.ebuild 1394 BLAKE2B 4fdc890f870682587d82934bf1971f65b0dc1b866435bf4b9d270790522259a0e4782e26f996c40eda40c039c5101543cc9ac5fcec52edeb27cd0e330ba4ead8 SHA512 b7ed8b66849601b1dd04129dac0bfd40a40355c2fcf553c7d915bccd9c098de1ec54025acb88f744962720f6c88a1f8433d0d6127a0dd548692f08057211fc64
MISC metadata.xml 394 BLAKE2B 614051906b91544c8562f3779ce4e05d9eebb8cc36c127589787c250a6a25290819162613de570ec6ad3f6ad77e46fd39d6b279c834aed3b03bc793ea8da17e2 SHA512 173a7025f2cc59dbfa17f8c4e3750f0f6bcfa3d1837f2279dc0d5741fd7a580a83205aa49a52af593e13acd79c729dfcf6d13293e44203a1e0d9646c73abe7ad
diff --git a/dev-util/heaptrack/heaptrack-9999.ebuild b/dev-util/heaptrack/heaptrack-9999.ebuild
index 626643eac8ca..cb0a7bdb8024 100644
--- a/dev-util/heaptrack/heaptrack-9999.ebuild
+++ b/dev-util/heaptrack/heaptrack-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake kde.org xdg-utils
+inherit cmake desktop kde.org xdg-utils
DESCRIPTION="Fast heap memory profiler"
-HOMEPAGE="https://apps.kde.org/en/heaptrack
+HOMEPAGE="https://apps.kde.org/heaptrack/
https://milianw.de/blog/heaptrack-a-heap-memory-profiler-for-linux"
LICENSE="LGPL-2.1+"
@@ -14,12 +14,11 @@ SLOT="0"
KEYWORDS=""
IUSE="+gui test zstd"
-BDEPEND="
- gui? ( kde-frameworks/extra-cmake-modules:5 )
-"
+RESTRICT="!test? ( test )"
+
DEPEND="
- dev-libs/boost:=
- sys-libs/libunwind
+ dev-libs/boost:=[zstd?]
+ sys-libs/libunwind:=
sys-libs/zlib
gui? (
dev-libs/kdiagram:5
@@ -40,26 +39,32 @@ DEPEND="
RDEPEND="${DEPEND}
gui? ( >=kde-frameworks/kf-env-4 )
"
+BDEPEND="
+ gui? ( kde-frameworks/extra-cmake-modules:5 )
+"
-RESTRICT+=" !test? ( test )"
+src_prepare() {
+ cmake_src_prepare
+ rm -rf 3rdparty/boost-zstd || die # ensure no bundling
+}
src_configure() {
local mycmakeargs=(
-DHEAPTRACK_BUILD_GUI=$(usex gui)
-DBUILD_TESTING=$(usex test)
- $(cmake_use_find_package zstd Zstd)
+ $(cmake_use_find_package zstd ZSTD)
)
cmake_src_configure
}
-xdg_pkg_postinst() {
+pkg_postinst() {
if use gui; then
xdg_desktop_database_update
xdg_icon_cache_update
fi
}
-xdg_pkg_postrm() {
+pkg_postrm() {
if use gui; then
xdg_desktop_database_update
xdg_icon_cache_update