summaryrefslogtreecommitdiff
path: root/dev-util/gyp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-util/gyp
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-util/gyp')
-rw-r--r--dev-util/gyp/Manifest6
-rw-r--r--dev-util/gyp/gyp-20200512145953.ebuild (renamed from dev-util/gyp/gyp-20170904022846-r1.ebuild)22
-rw-r--r--dev-util/gyp/gyp-99999999999999.ebuild17
3 files changed, 36 insertions, 9 deletions
diff --git a/dev-util/gyp/Manifest b/dev-util/gyp/Manifest
index d9d89b990d6c..ee97450eddd0 100644
--- a/dev-util/gyp/Manifest
+++ b/dev-util/gyp/Manifest
@@ -1,4 +1,4 @@
-DIST gyp-20170904022846.tar.xz 447608 BLAKE2B 41f0e28d04039358a9e4ec9628fe1d936d19748061ea882a4e47f2cb23549db3866c5281e102b8f95d6ed37cfe999e7342129a81333671ee42534fc53d2a0d0e SHA512 9336be1103048fe5f51f90fcb2a153bba7638e71e4b579c47b725db81ae4257a56a8f7dacddc936e627862ee6149a453f1c7f5bede633cbd3076e0fa2fce07a7
-EBUILD gyp-20170904022846-r1.ebuild 788 BLAKE2B 2fb14abe495c217952de94a24ba9a1d7e634dddd91139f3f20df2d97b5f78acd6fab936fe6839b92a02703889e8799aa32430713069ff86b3e092772ba887d51 SHA512 68912342b6876b7d5d3c8588fb15c19316353090da62b04aef730c06a9a706436bb8ed0d12134b2a63af709c2e5dfcdecc973fbb8760eac1e6cfb5a487a470ab
-EBUILD gyp-99999999999999.ebuild 839 BLAKE2B 23211f1919910dad238ec6c1bda075cf5fa738a8b1b4e0bc1ce5b9139f81d516d3a59dfa705f97815700c600416fffc21b6692c3a75507a7e9b9652b3a949bf0 SHA512 b80be2b5679e6c06c09264b711636593a19a709828bd0c4e4343d8784b56708c4165ffa51ea2e94b8e5d5f4518ee9a7161f00fb57f4bb4d4683ba84b80c21ae0
+DIST gyp-20200512145953.tar.xz 443884 BLAKE2B 74ff269e3e8aa51e6b34f795892f6e8922d098a81b4d855619520d3d366e79b611931cddf4ee2ec60a7e040af11ac8eba7582ad10e24de627df5a4aa4eba6474 SHA512 35bf2af22f2e632b3d6e546e5017df8effd0c7ad80beed9b95ed1e2f294d70215889bc6a0147506461254e951d70189dc48824af10a6620e996945d2cf5586ee
+EBUILD gyp-20200512145953.ebuild 1289 BLAKE2B 1c4f2b4adc041fccaace6c4341aa6fdd7b98733a871d65398514bf6032525d9809089be4b522fe469a856c4a390b45a096f3352764f7e677752b8f1a9ab1efc7 SHA512 135cc599f3a6a5bd15ba7303260b5cbdda8a5ae1520d8ad136fb1443b71df63ffa4ea5e3fcbefdcf4157a2a299328ea2adb25197501173a70a2d3ef5faf6f951
+EBUILD gyp-99999999999999.ebuild 1266 BLAKE2B f4020ae01454a7141fa18ce8a8c66aed1143462992bc54e553e33a5189a1e4f7f687c3c134b62abac3d3c90abc470c493d92e040da5f87841d2108a2ef996fa9 SHA512 a7ad2fb23ac45acd63a8a42926f46c1a4fab63f7e03b6c3cbdfcf72b1b683fc0104fc31af89c7d433bf85d6b5f9366d29d67116071a798de42ff2db8b1219a63
MISC metadata.xml 415 BLAKE2B bee460235492c13da7eb83441f00a502d900c169b48c91802a8891f9856c5f87aa225e61d8efd90ac2aade3ec52a93db293e3927b73c9b9b2708f723370d8585 SHA512 378e53a81fa2177409ae4557c336ddfb62b8657bf2d756ae651011d5dc5e94604d52aece3cdda38fbd0f123d5a1f83b721ccee3ecc5870cc562670fd748631c9
diff --git a/dev-util/gyp/gyp-20170904022846-r1.ebuild b/dev-util/gyp/gyp-20200512145953.ebuild
index 4c94b7b218e3..9ee7379992fa 100644
--- a/dev-util/gyp/gyp-20170904022846-r1.ebuild
+++ b/dev-util/gyp/gyp-20200512145953.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python2_7)
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
DISTUTILS_SINGLE_IMPL="1"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1
@@ -26,8 +27,23 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 x86"
IUSE=""
-src_test() {
- # More errors when DeprecationWarnings enabled.
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
+ sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
+ sed \
+ -e "s/os\.environ\['PRESERVE'\] is not ''/os.environ['PRESERVE'] != ''/" \
+ -e "s/conditions is ()/conditions == ()/" \
+ -i test/lib/TestCmd.py || die
+}
+
+python_test() {
+ # More errors with DeprecationWarnings enabled.
local -x PYTHONWARNINGS=""
"${PYTHON}" gyptest.py --all --verbose
diff --git a/dev-util/gyp/gyp-99999999999999.ebuild b/dev-util/gyp/gyp-99999999999999.ebuild
index da57f66635d9..bf36a597b2c0 100644
--- a/dev-util/gyp/gyp-99999999999999.ebuild
+++ b/dev-util/gyp/gyp-99999999999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python{3_6,3_7})
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
DISTUTILS_SINGLE_IMPL="1"
DISTUTILS_USE_SETUPTOOLS="rdepend"
@@ -31,8 +31,19 @@ BDEPEND=""
DEPEND=""
RDEPEND=""
-src_test() {
- # More errors when DeprecationWarnings enabled.
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -e "s/' Linux %s' % ' '\.join(platform.linux_distribution())/' Linux'/" -i gyptest.py || die
+ sed -e "s/the_dict_key is 'variables'/the_dict_key == 'variables'/" -i pylib/gyp/input.py || die
+ sed \
+ -e "s/os\.environ\['PRESERVE'\] is not ''/os.environ['PRESERVE'] != ''/" \
+ -e "s/conditions is ()/conditions == ()/" \
+ -i test/lib/TestCmd.py || die
+}
+
+python_test() {
+ # More errors with DeprecationWarnings enabled.
local -x PYTHONWARNINGS=""
"${PYTHON}" gyptest.py --all --verbose