summaryrefslogtreecommitdiff
path: root/dev-util/gtk-doc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/gtk-doc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/gtk-doc')
-rw-r--r--dev-util/gtk-doc/Manifest5
-rw-r--r--dev-util/gtk-doc/files/61gtk-doc-gentoo.el9
-rw-r--r--dev-util/gtk-doc/files/gtk-doc-1.8-emacs-keybindings.patch17
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.25-r1.ebuild109
-rw-r--r--dev-util/gtk-doc/metadata.xml19
5 files changed, 159 insertions, 0 deletions
diff --git a/dev-util/gtk-doc/Manifest b/dev-util/gtk-doc/Manifest
new file mode 100644
index 000000000000..dfec8b299d66
--- /dev/null
+++ b/dev-util/gtk-doc/Manifest
@@ -0,0 +1,5 @@
+AUX 61gtk-doc-gentoo.el 283 BLAKE2B 116d2b43d42b05130482c5bff7a10f13930a0d04f34874d25bfa6c61dc8920efe60ae615e6d54de1eeed87044a7232a992a37582d608b0756f0b099b5ee62d03 SHA512 d9e7c8bacd97a5147dbbe9ad568323356c9c38ad982ce88c63ef5f8e3955289274393a91e07d2159c082ac2a058455a1905c251ff3676f60bad596379fb12837
+AUX gtk-doc-1.8-emacs-keybindings.patch 582 BLAKE2B 9591f8f58dbd2c5897abf020f96a3ad8124830c274bfa581756ccaa43c67002264cc6d5a04c0316e4bb2dfa75a3cb08b5de6217a81a295b3a31e18dae8d1ad7d SHA512 360e97c0d2603c17dd1c1ca92739eb5ac229f3bcda6dc76267b95cac73db1008a52164ac9cba5a0e43f7b6359b5e6d3b242fde757fa1b7409051bade5f6f35a6
+DIST gtk-doc-1.25.tar.xz 673184 BLAKE2B 2468b70403c0334b52ce1bcb77d2015fe83e0af9fac861464db605de9744ec1c7300e9b9a4b4fe0a3641e016083df063d92e1b74e44771d7a88c66815a396765 SHA512 7ac8c73ab9f9ecb6a142bd2232450a6431c3e4fe2372ff40460145b5d0bcffa1953c8cf49436539db86c3a32461cbd4180c714cb19cdd68bfd557816b789339c
+EBUILD gtk-doc-1.25-r1.ebuild 2577 BLAKE2B 110bf184a66013282cfaa51032a161eb9ae5ccf19acf42024de136c20921475e6e439fa5c5ac0750e86b6b40d4ac0b70dc09a7b9a2a5bedcf7038a236c14734e SHA512 668b64a119f6895c8f03940155a01ce0fc95e1fc8c7504eb7b2b459b8b29dde8b2696ae619005214a0c29c5ce1dbb4a614cc7a5137553e37ff5d98e9e1ebbb43
+MISC metadata.xml 659 BLAKE2B 8c57567cad76724388d746e74bd1056a062c7280552494d6265b5fa38be518983188f22948bdb389916ec6384c17308e1ec292ec36f633b6ecd6f27102f74f94 SHA512 4ffcd239d0a5788ed94a204395a51d8b706663ac69139965e7d28282c473b55cd006cf3786a3cfd60386439f9ffa5d9242ed43ba05783962cbac002f8a00539b
diff --git a/dev-util/gtk-doc/files/61gtk-doc-gentoo.el b/dev-util/gtk-doc/files/61gtk-doc-gentoo.el
new file mode 100644
index 000000000000..488a57c02555
--- /dev/null
+++ b/dev-util/gtk-doc/files/61gtk-doc-gentoo.el
@@ -0,0 +1,9 @@
+
+;;; gtk-doc site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'gtk-doc-insert "gtk-doc"
+ "Add a documentation header to the current function." t)
+(autoload 'gtk-doc-insert-section "gtk-doc"
+ "Add a section documentation header at the current position." t)
diff --git a/dev-util/gtk-doc/files/gtk-doc-1.8-emacs-keybindings.patch b/dev-util/gtk-doc/files/gtk-doc-1.8-emacs-keybindings.patch
new file mode 100644
index 000000000000..bbc989afb2b7
--- /dev/null
+++ b/dev-util/gtk-doc/files/gtk-doc-1.8-emacs-keybindings.patch
@@ -0,0 +1,17 @@
+--- gtk-doc-1.8-orig/tools/gtk-doc.el 2007-01-03 16:04:14.000000000 +0100
++++ gtk-doc-1.8/tools/gtk-doc.el 2007-07-29 21:56:45.000000000 +0200
+@@ -262,7 +262,7 @@
+
+ ;; set global binding for this key (follows the format for
+ ;; creating a changelog entry ...)
+-(global-set-key "\C-x4h" 'gtk-doc-insert)
++;;(global-set-key "\C-x4h" 'gtk-doc-insert)
+
+
+ ;; Define another function for inserting a section header.
+@@ -280,4 +280,4 @@
+ " */\n"))
+
+ ;; Set the key binding.
+-(global-set-key "\C-x4s" 'gtk-doc-insert-section)
++;;(global-set-key "\C-x4s" 'gtk-doc-insert-section)
diff --git a/dev-util/gtk-doc/gtk-doc-1.25-r1.ebuild b/dev-util/gtk-doc/gtk-doc-1.25-r1.ebuild
new file mode 100644
index 000000000000..155f1f6a02f9
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.25-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils elisp-common gnome2 python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="https://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+
+IUSE="debug doc emacs highlight vim"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.6:2
+ >=dev-lang/perl-5.18
+ dev-libs/libxslt
+ >=dev-libs/libxml2-2.3.6:2
+ ~app-text/docbook-xml-dtd-4.3
+ app-text/docbook-xsl-stylesheets
+ ~app-text/docbook-sgml-dtd-3.0
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ emacs? ( virtual/emacs )
+ highlight? (
+ vim? ( || ( app-editors/vim app-editors/gvim ) )
+ !vim? ( dev-util/source-highlight )
+ )
+"
+DEPEND="${RDEPEND}
+ ~dev-util/gtk-doc-am-${PV}
+ app-text/yelp-tools
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ DOC_CONTENTS="gtk-doc does no longer define global key bindings for Emacs.
+ You may set your own key bindings for \"gtk-doc-insert\" and
+ \"gtk-doc-insert-section\" in your ~/.emacs file."
+ SITEFILE=61${PN}-gentoo.el
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Remove global Emacs keybindings, bug #184588
+ eapply "${FILESDIR}"/${PN}-1.8-emacs-keybindings.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ if use vim; then
+ myconf="${myconf} $(use_with highlight highlight vim)"
+ else
+ myconf="${myconf} $(use_with highlight highlight source-highlight)"
+ fi
+
+ gnome2_src_configure \
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
+ $(use_enable debug) \
+ ${myconf}
+}
+
+src_compile() {
+ gnome2_src_compile
+ use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+ gnome2_src_install
+
+ python_fix_shebang "${ED}"/usr/bin/gtkdoc-depscan
+
+ # Don't install those files, they are in gtk-doc-am now
+ rm "${ED}"/usr/share/aclocal/gtk-doc.m4 || die "failed to remove gtk-doc.m4"
+ rm "${ED}"/usr/bin/gtkdoc-rebase || die "failed to remove gtkdoc-rebase"
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ docinto examples
+ dodoc examples/*
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} tools/gtk-doc.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ readme.gentoo_create_doc
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use emacs; then
+ elisp-site-regen
+ readme.gentoo_print_elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/gtk-doc/metadata.xml b/dev-util/gtk-doc/metadata.xml
new file mode 100644
index 000000000000..1a3871ad27fb
--- /dev/null
+++ b/dev-util/gtk-doc/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="highlight">Enable source code highlighting</flag>
+ <flag name="vim">Enable source code highlighting through
+ <pkg>app-editors/vim</pkg></flag>
+</use>
+<longdescription lang="en">
+ GTK-Doc is used to document C code.
+ It is typically used to document the public API of libraries,
+ such as the GTK+ and GNOME libraries, but it can also be used
+ to document application code.
+</longdescription>
+</pkgmetadata>