summaryrefslogtreecommitdiff
path: root/dev-util/gquilt/gquilt-0.25-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/gquilt/gquilt-0.25-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/gquilt/gquilt-0.25-r1.ebuild')
-rw-r--r--dev-util/gquilt/gquilt-0.25-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/gquilt/gquilt-0.25-r1.ebuild b/dev-util/gquilt/gquilt-0.25-r1.ebuild
new file mode 100644
index 000000000000..ce0e5f51b9c6
--- /dev/null
+++ b/dev-util/gquilt/gquilt-0.25-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A Python/GTK wrapper for quilt"
+HOMEPAGE="http://gquilt.sourceforge.net/ https://sourceforge.net/projects/gquilt/"
+SRC_URI="mirror://sourceforge/gquilt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk:2[${PYTHON_USEDEP}]
+ || ( dev-util/quilt dev-vcs/mercurial )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+PATCHES=( "${FILESDIR}"/${P}-desktopfile.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu ${PN}.desktop
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}