summaryrefslogtreecommitdiff
path: root/dev-util/gource
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-util/gource
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-util/gource')
-rw-r--r--dev-util/gource/Manifest2
-rw-r--r--dev-util/gource/gource-0.51.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/gource/Manifest b/dev-util/gource/Manifest
index 02d3ccd0265e..feba071ed2d3 100644
--- a/dev-util/gource/Manifest
+++ b/dev-util/gource/Manifest
@@ -1,3 +1,5 @@
DIST gource-0.49.tar.gz 874349 BLAKE2B b7d24f415944921deb7df33be4e9918291f5df6dd4813bf98727894e0192b881a583a1dacec2d6e8f2d1a0d6b644bc3b735ef8d7c0b7882d77bcd80913fe08c5 SHA512 cb3482dd06cf38bd775f2ac4b8f3bee78e480dd51e37527024df6e59d6e613290297d65e167a21364aa6251eff78a50ecc8a5fd3772a6e9a4ad22ca21b4b615e
+DIST gource-0.51.tar.gz 882783 BLAKE2B 86a95a55ef9e1ec50e19a4859163d7cdc2733b7c55a68e4d2db493e4c6587682b900b2c73525131972da4dde9fc4d9fa41ba728bdc56fd46fc6a559cb4d837f0 SHA512 f29326ffb2aa6f645fb941e08e41f0cbf8dd894d5a4d607b782caeb12a24e6446198027060b880e0ad14a36efbed19023620dd8c890cfc0c027fc90ac2d5be24
EBUILD gource-0.49.ebuild 1067 BLAKE2B 239950d5088a2a7d8901b60b1b5514a27aae8b4065a1ed6db44d123236bc1bccdf200ed6d3371b331702cf49032aeb162e201d29febc3d552f991034e45efad3 SHA512 f8511d169bb3db902d7bd9f0aa4c0a33cae3d92123a234d516b0ce03044217cdd846241bc979151c683282c9f457eaeb5daf011d283592114135e2a117a5e8f4
+EBUILD gource-0.51.ebuild 1075 BLAKE2B ce94c79fa5fdfabd9a15febdc0582a45ee960b4ee080f218eb49102a887775b87ab22c8b5e994b6ff980e6168fb9beedf71e8487dc12891160ec66c84ed225ac SHA512 6d51fbe38fe6d807c48fd760f8b59ed3cefb286a9c56b5e08ee3b948bb9ba82aa5591be2f25237c4473acf5304fd215dd0e2c268c9f1177b911a4592dc8f58b5
MISC metadata.xml 353 BLAKE2B 86c28b45e78dacf7183e323130cd947f36f88278cbfca6d5e50d52268f309394d934836ca6a150af8297a153025c1be7756ba7cbc5ac7088bf2fff763f3b85d9 SHA512 d203593d1819671dc81ede02a2c7fdfc81f69b9d66a6587fd096ea89ca3274adba144f06244792f2044f8c8bfc788fbebbc6eca20a7cd9b5da18f3c1fb392729
diff --git a/dev-util/gource/gource-0.51.ebuild b/dev-util/gource/gource-0.51.ebuild
new file mode 100644
index 000000000000..a1e9aa52d6f9
--- /dev/null
+++ b/dev-util/gource/gource-0.51.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A software version control visualization tool"
+HOMEPAGE="https://gource.io/"
+SRC_URI="https://github.com/acaudwell/Gource/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/boost-1.46:=[threads(+)]
+ >=media-libs/glew-1.5:0=
+ >=media-libs/libpng-1.2:0=
+ media-libs/libsdl2[video,opengl,X]
+ media-libs/sdl2-image[jpeg,png]
+ dev-libs/libpcre:3
+ dev-libs/tinyxml
+ media-libs/freetype:2
+ media-libs/mesa[X(+)]
+ virtual/glu:0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/freefont
+"
+DEPEND="${COMMON_DEPEND}
+ >=media-libs/glm-0.9.3
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README ChangeLog THANKS )
+
+src_configure() {
+ # fix bug #386525
+ # this enables gource to be compiled against dev-libs/tinyxml[stl]
+ if has_version dev-libs/tinyxml[stl]; then
+ append-cppflags -DTIXML_USE_STL;
+ fi
+
+ econf \
+ --enable-ttf-font-dir=/usr/share/fonts/freefont/ \
+ --with-tinyxml
+}