summaryrefslogtreecommitdiff
path: root/dev-util/gn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /dev-util/gn
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'dev-util/gn')
-rw-r--r--dev-util/gn/Manifest2
-rw-r--r--dev-util/gn/gn-0.2049.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/gn/Manifest b/dev-util/gn/Manifest
index ab64f6726d45..0f286d5fb5fc 100644
--- a/dev-util/gn/Manifest
+++ b/dev-util/gn/Manifest
@@ -1,4 +1,6 @@
AUX gn-gen-r5.patch 1563 BLAKE2B ff909ef01743ca36d866257ad3bc2a1ca7a4e894b6a0c7672d08d0e1cd412b1056477f77ab64c75fa67a5c21794cecdd87f6bb75ebd963fff0ee3599523c73f6 SHA512 bb18dc2900084ca15ee12addec56d32cce520cb0d229bddbb69e8da7cca144887a6eb7267ea449613505dca4cdeba8ef0e4e69595fc202289d2f3c5fed2e4971
DIST gn-0.1943.tar.xz 706792 BLAKE2B 51889ad85e86e702c2690c5c23010d666ef0467be92d982e6dea2eec2e20774c04425900cad64672c7782bf36e62984e612c04ff0f1c7e9598f2877270cf8504 SHA512 4e3270e13e35fa0ede3c81b563b72a9e9baee18b6412d32603d3c7a327315ceea86dc28c9c3b01c9e9f4d520e222dfeabe152f946eb0947d9285359568934864
+DIST gn-0.2049.tar.xz 727960 BLAKE2B fe93d09c1fa5b6267a4d26f37ec42e629b36645ef58bf6ebcc07dd8cd2ee9509c1e997182251a3e2c3ef3c5b7d636c9a8228c1e49d1d7245b3ebdac36e7c5a1a SHA512 f3e6dc87d647702c5d22793e2eed3e9950f8c9a6d7178eae67bb7d6518b6533c74fa3f43245fb9e422994a27f1a0f1986709f91e7ce2ed78eb5f17838f75e1db
EBUILD gn-0.1943.ebuild 1294 BLAKE2B 702eebb55f4f625f6cf649a865e6801bb541249fe4d8abfbb2b4254dfb6557e8321304664ffe144794454014a6854ade8f90bca903568cb9a3aa41ff07947469 SHA512 28eac75e4ecd6d4e2323ce1ec9161ee5d80e10b1706edd6931ab9c5169b8c68d7e33af3aa9c061cd1f2c9397e312e82ec079d43846f83da1c0132d32393610bc
+EBUILD gn-0.2049.ebuild 1319 BLAKE2B 414ac7c17df00df8bc64a40a211ad3b07b1a33cf34946e2aff3205d4391f1bb6a6c5a7dc223b47b80438d8235a6f7c17f00bd1a29cf84df2cd4889022863865f SHA512 8d330d34745688f8005745a769df4b5b3e2b198aa85a503bc6bb924f5cab5920a641bdf51b68262555b21db240f303cb93c77bee80f9f3a7730aaf04431bca20
MISC metadata.xml 221 BLAKE2B ce7615d8eda5f58e7729bf86156010821052ae580769c3be3922f1270f1211bc5cf297afc5c68db67a46c1c01450c08751fc3cda0995d62bbe60da64d21802d6 SHA512 6ffee27f859f923795e8ded3a5544a82473f72568e96475374b937adbf0963f81d46fbcf4752a9d4eef3f071cadd3dedf141f43802b58c6a788243c7f05114cf
diff --git a/dev-util/gn/gn-0.2049.ebuild b/dev-util/gn/gn-0.2049.ebuild
new file mode 100644
index 000000000000..e8ce49ec53a2
--- /dev/null
+++ b/dev-util/gn/gn-0.2049.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit ninja-utils python-any-r1 toolchain-funcs
+
+DESCRIPTION="GN is a meta-build system that generates build files for Ninja"
+HOMEPAGE="https://gn.googlesource.com/"
+SRC_URI="https://dev.gentoo.org/~xen0n/distfiles/dev-util/gn/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="vim-syntax"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ninja
+"
+
+PATCHES=(
+ "${FILESDIR}"/gn-gen-r5.patch
+)
+
+pkg_setup() {
+ :
+}
+
+src_configure() {
+ python_setup
+ tc-export AR CC CXX
+ unset CFLAGS
+ set -- ${EPYTHON} build/gen.py --no-last-commit-position --no-strip --no-static-libstdc++ --allow-warnings
+ echo "$@" >&2
+ "$@" || die
+ cat >out/last_commit_position.h <<-EOF || die
+ #ifndef OUT_LAST_COMMIT_POSITION_H_
+ #define OUT_LAST_COMMIT_POSITION_H_
+ #define LAST_COMMIT_POSITION_NUM ${PV##0.}
+ #define LAST_COMMIT_POSITION "${PV}"
+ #endif // OUT_LAST_COMMIT_POSITION_H_
+ EOF
+}
+
+src_compile() {
+ eninja -C out gn
+}
+
+src_test() {
+ eninja -C out gn_unittests
+ out/gn_unittests || die
+}
+
+src_install() {
+ dobin out/gn
+ einstalldocs
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r misc/vim/{autoload,ftdetect,ftplugin,syntax}
+ fi
+}