summaryrefslogtreecommitdiff
path: root/dev-util/glade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-11 20:20:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-11 20:20:26 +0100
commitf4ab034d81402342178d7cca4689e01193cd38ca (patch)
treec3251496d2bb336863c2ed7af224fca7868290ac /dev-util/glade
parent34d4f34516ab568ad4ea24fc16ee0ad9ec8ad079 (diff)
gentoo auto-resync : 11:08:2022 - 20:20:26
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/Manifest2
-rw-r--r--dev-util/glade/glade-3.40.0.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-util/glade/Manifest b/dev-util/glade/Manifest
index eb480aa9f163..e82e87f41ef6 100644
--- a/dev-util/glade/Manifest
+++ b/dev-util/glade/Manifest
@@ -1,5 +1,7 @@
AUX glade-3.14.1-doc-version.patch 853 BLAKE2B b7cad3cc9d49cfe24189ba21bffaec2c524d3c7953d722b3b03d57ad68297fee6757330c1a2d90f36bcfe52d1d9ef4d95b81eeb19109bc8957f671ac40d31573 SHA512 cc9aec06f6acdfdf538de7043f9f753768e0e4c26fa9eef7e52b4e42aa6fd3836185c18ffd51abfc2aa3e6f5b2472e68914112230d2b8856e8a3c61e9d865ecf
AUX glade-3.38.2-meson-0.61.patch 1334 BLAKE2B 009af5a6617b59519eec3c4033d63f898ca71621628ef519da6d0ea68bc16e588f74b04d972c405c554a3f7f608e1704a1dd314a030b890c8b52e46ac0b7d8af SHA512 3248d5faf635a15303e8249637608b840b699208f1caae2d21e612caf3826a15de71456764ef98b801eb97fe3fe19e71fd868528a502d5540df4bb7ae75dbf11
DIST glade-3.38.2.tar.xz 2709224 BLAKE2B 2bcd447b90d6e67abc44dd273f0f5d7fc1d6848ef0bd878481f2c10e8846828e63fbf9c9c96e5effe8126b4aec7eb05886606ca1dc5fb94943bc5d1d8d0ef4e2 SHA512 2df8c8363206905663cd3ac9196da44445425a888b64f1b3b3ac6cd41e14c4a82a5d2c299730ef0606c3970a04dd8f245bb5639218794eb67dcbd26fae17565e
+DIST glade-3.40.0.tar.xz 2654772 BLAKE2B 472dfd841e9501f7bbc96bde49ebe26dfd54193cd479658d042547eba5d1af196c0a06212ec5c894c53c12f3791967f6c77859f96802e3df5760b36c6c0c4af1 SHA512 6b018f882e9d155a4b2256c0b4c72743f971c8d730a53f16faa240d01e14051f5b6ce04e355dcc78e1679579fb091facaa06acdda6297c5b8efc642c42bb7b4e
EBUILD glade-3.38.2-r1.ebuild 2008 BLAKE2B b9869b6d34e51d97199cd8b8ca8271c91cee76ffa177f2917bbf71e656e362f5772434893061189ce3c15a5e4120119ddd34ed38b308ea7a00b047af2da03e77 SHA512 9a4102ff48256be6c7528b3607bc0184469d1055a27f8e0cb4429e1a7e5386d9ae2274464d9bee4ca88c879fa9351892058b78e2e19ab935d35802b93a06aeab
+EBUILD glade-3.40.0.ebuild 1971 BLAKE2B 1e0545706571cfbfdfa238740bdc4f6a7306dac6432cb828b7a286149cdc5c54941508f9629ef0bdce9586974253797ac4ac4f6cdd8dbc41117909a252812b84 SHA512 bab7adc8f20fe2683fabc9c5362a5875b4db7bd57f5f8fb8e49ed0a2154df9d3760cc60cf2cff7d7da6f68bd5f16081a2bd67b7f2fd40f4f4bb441bc8a3104d4
MISC metadata.xml 443 BLAKE2B 26f4701b1aaa6e751e838240b2c5d5f45b76b5dc2a5321a2f58384f9afa25ddd0409722cbe8865fb160272968babdc9145cbeb9ff3602697a7aaec3c9d5e6db6 SHA512 6a334008fb56ba68d64a0f1c064032b9677d8891bb0af7d6f9a02ee5408dfccb2e917f64ece43bc2e9b3ea740a29f2bae12b7fa14c07b7c6dca388d2e9725af8
diff --git a/dev-util/glade/glade-3.40.0.ebuild b/dev-util/glade/glade-3.40.0.ebuild
new file mode 100644
index 000000000000..6204835b1876
--- /dev/null
+++ b/dev-util/glade/glade-3.40.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome2 python-single-r1 meson optfeature virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org https://gitlab.gnome.org/GNOME/glade"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/13" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="gjs gtk-doc +introspection python webkit"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.53.2:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.22.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ gjs? ( >=dev-libs/gjs-1.64.0 )
+ python? (
+ ${PYTHON_DEPS}
+ x11-libs/gtk+:3[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+ ')
+ )
+ webkit? ( >=net-libs/webkit-gtk-2.12.0:4 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="test" # https://gitlab.gnome.org/GNOME/glade/issues/333
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dgladeui=true
+ $(meson_feature gjs)
+ $(meson_feature python)
+ $(meson_feature webkit webkit2gtk)
+
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ optfeature_header
+ optfeature "integration API documentation support" dev-util/devhelp
+}