summaryrefslogtreecommitdiff
path: root/dev-util/glade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /dev-util/glade
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/Manifest2
-rw-r--r--dev-util/glade/glade-3.20.4.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/glade/Manifest b/dev-util/glade/Manifest
index 3b82e78ce884..31c1ba4ddcf4 100644
--- a/dev-util/glade/Manifest
+++ b/dev-util/glade/Manifest
@@ -1,4 +1,6 @@
AUX glade-3.14.1-doc-version.patch 853 BLAKE2B b7cad3cc9d49cfe24189ba21bffaec2c524d3c7953d722b3b03d57ad68297fee6757330c1a2d90f36bcfe52d1d9ef4d95b81eeb19109bc8957f671ac40d31573 SHA512 cc9aec06f6acdfdf538de7043f9f753768e0e4c26fa9eef7e52b4e42aa6fd3836185c18ffd51abfc2aa3e6f5b2472e68914112230d2b8856e8a3c61e9d865ecf
DIST glade-3.20.2.tar.xz 3535064 BLAKE2B 33e5e9477556ac5f645cf13658ff1eebdaf046c1bbbcf5ac528c00f9b5f76943ede8140cc6a3b73dc27ed96c363208700031306f19478ba0e9e2fbae8319f500 SHA512 45f850ed4d409aaf11153da45398e7974d7b85235bf5d5043bc11755c3e4d1201f59ed854786162a7414f0521c818982560d4e226f93625b9253dc598793118a
+DIST glade-3.20.4.tar.xz 3534860 BLAKE2B f502e863f9acbd6580c043ff82dffb84ea8fdb833c0b6fdb8bbeeb7a7056a79416f1140472d23e0cdb14ed3bd06e17fca93ea663af690451001909aa4abfe478 SHA512 3da7781f74fa80e21336e49b9b36cf73b88ec9cf6f66a5c0e5d48ebc3382d87f5eb981b924704f04dfa4931e5691928a20c7cc73cca5b5f3a32e2348d6b87802
EBUILD glade-3.20.2.ebuild 2390 BLAKE2B bcf33fb3b36f7f38c7b91343ed1c0a6ecbd171a42b1ee252009902569ea327c43e1b9b47d04c6c0a87ed9910e1873f9800c1bb566ef160c0258400252b83cb3a SHA512 b540957231160447eaf0dbe056a312e9fc9506db0b83271f7fff63c438be56d76b2bcf5d861d2ad3dd7f9be661250141531b7076a5ae14e2c582c89284170e60
+EBUILD glade-3.20.4.ebuild 2398 BLAKE2B fbeaba8d2b275218160e38bd2ecdde8872c65741e0c37d9244ca51d79025a1096b1dba2e5f63a45d9c4322709db54bcd1a2f01fb060a58c6e7bf7dfb76183771 SHA512 1e8fbf054ac69b453a42629bb97ab8022a2e4b9f82f606f798b2195a3d50735182c5877c4a3043f6034bb0458ad5207e916d88fe83db969fb3ac01d5c1f88c6c
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-util/glade/glade-3.20.4.ebuild b/dev-util/glade/glade-3.20.4.ebuild
new file mode 100644
index 000000000000..243a72912856
--- /dev/null
+++ b/dev-util/glade/glade-3.20.4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 versionator virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/6" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+IUSE="debug +introspection python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.20.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gladeui \
+ --enable-libtool-lock \
+ $(usex debug --enable-debug ' ') \
+ $(use_enable introspection) \
+ $(use_enable python)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ # modify Name in .desktop file to avoid confusion with other slots
+ sed -e 's:^\(Name.*=Glade\):\1 '$(get_version_component_range 1-2): \
+ -i data/glade.desktop || die "sed of data/glade.desktop failed"
+ # modify name in .devhelp2 file to avoid shadowing with glade:3 docs
+ sed -e 's:name="gladeui":name="gladeui-2":' \
+ -i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version dev-util/devhelp ; then
+ elog "You may want to install dev-util/devhelp for integration API"
+ elog "documentation support."
+ fi
+}