summaryrefslogtreecommitdiff
path: root/dev-util/glade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-18 15:11:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-18 15:11:02 +0000
commit0fb71e0215ed52863e462cccef73c01aff44d43d (patch)
tree428fc3fa92f9c69ed02878e9b6151a9fb810e651 /dev-util/glade
parent9bd54251864651f49e673a08aec9ef79cfe08f04 (diff)
gentoo resync : 18.12.2017
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/Manifest2
-rw-r--r--dev-util/glade/glade-3.20.2.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/glade/Manifest b/dev-util/glade/Manifest
index 4c34342baeb5..4d90b85607a5 100644
--- a/dev-util/glade/Manifest
+++ b/dev-util/glade/Manifest
@@ -1,4 +1,6 @@
AUX glade-3.14.1-doc-version.patch 853 BLAKE2B b7cad3cc9d49cfe24189ba21bffaec2c524d3c7953d722b3b03d57ad68297fee6757330c1a2d90f36bcfe52d1d9ef4d95b81eeb19109bc8957f671ac40d31573 SHA512 cc9aec06f6acdfdf538de7043f9f753768e0e4c26fa9eef7e52b4e42aa6fd3836185c18ffd51abfc2aa3e6f5b2472e68914112230d2b8856e8a3c61e9d865ecf
DIST glade-3.20.0.tar.xz 3492928 BLAKE2B bab8682ec83a98f7f405a667e9fc9ad4b0fa334e0f1f3b1ba5bd8e17af1c61c65031ebe2fe56b8321df142f5a4d8dec348793bba0fc3c195c6722d635d52a291 SHA512 58c8da3522c75470f5b42492bddd83f61d828fa2a3fb8a78d15813f6d1f1df22bd808f25ae7228bf2e821bacdcc5665b889bac3ea8364c4dac288f95e817e98a
+DIST glade-3.20.2.tar.xz 3535064 BLAKE2B 33e5e9477556ac5f645cf13658ff1eebdaf046c1bbbcf5ac528c00f9b5f76943ede8140cc6a3b73dc27ed96c363208700031306f19478ba0e9e2fbae8319f500 SHA512 45f850ed4d409aaf11153da45398e7974d7b85235bf5d5043bc11755c3e4d1201f59ed854786162a7414f0521c818982560d4e226f93625b9253dc598793118a
EBUILD glade-3.20.0.ebuild 2390 BLAKE2B 22cd5f2417192d963cbb2ff1376d9fa4b5eb44aba78f53c233dc5fd159fb93fa2c03096d71a35cd89321dd2d1f28092a503a4fd0f5cc8883da76854d9a470292 SHA512 98673ca19010e2a63c5c7c9c79dbfdb65939324004c7be6d8b846684411af444ef1fc499234296bfff24d5f8e03842781378d6099356af8b6dc236e757bdf047
+EBUILD glade-3.20.2.ebuild 2398 BLAKE2B e647eac6105adaaf6f8831b200e1f5095cedb7ec7129a8c1fefd7992c42747bc0f9f939d72f907838b5cf33ff7d3ce53a02bd305d2f67d62b380363794882045 SHA512 0743e8e2f3216d4f2c79d520ae58d8d521f59b60fa5093568c8714a8eb39e54e1533a2f106cd1e34baf5bc87eb53b1bec9dc7c5c0a18cb4d80e5b1e6bd4f0105
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-util/glade/glade-3.20.2.ebuild b/dev-util/glade/glade-3.20.2.ebuild
new file mode 100644
index 000000000000..2f8c73bbc2ca
--- /dev/null
+++ b/dev-util/glade/glade-3.20.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 versionator virtualx
+
+DESCRIPTION="A user interface designer for GTK+ and GNOME"
+HOMEPAGE="https://glade.gnome.org/"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="3.10/6" # subslot = suffix of libgladeui-2.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+IUSE="debug +introspection python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.20.0:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.41.0
+ dev-util/itstool
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+PATCHES=(
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ "${FILESDIR}"/${PN}-3.14.1-doc-version.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gladeui \
+ --enable-libtool-lock \
+ $(usex debug --enable-debug ' ') \
+ $(use_enable introspection) \
+ $(use_enable python)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ # modify Name in .desktop file to avoid confusion with other slots
+ sed -e 's:^\(Name.*=Glade\):\1 '$(get_version_component_range 1-2): \
+ -i data/glade.desktop || die "sed of data/glade.desktop failed"
+ # modify name in .devhelp2 file to avoid shadowing with glade:3 docs
+ sed -e 's:name="gladeui":name="gladeui-2":' \
+ -i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version dev-util/devhelp ; then
+ elog "You may want to install dev-util/devhelp for integration API"
+ elog "documentation support."
+ fi
+}