summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-util/gitlab-cli
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-util/gitlab-cli')
-rw-r--r--dev-util/gitlab-cli/Manifest3
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.25.3.ebuild32
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/Manifest b/dev-util/gitlab-cli/Manifest
index 333e5708adc7..d0ef1c895c9d 100644
--- a/dev-util/gitlab-cli/Manifest
+++ b/dev-util/gitlab-cli/Manifest
@@ -1,4 +1,7 @@
DIST gitlab-cli-1.24.1-deps.tar.xz 34979684 BLAKE2B 238ac4e1a4182cc2dd83a4a49f9306e2e76635a43297df21e022b9990eb20dc0eb3b06b16d0132f1b813fc7440ddcaf6335ef77afc3c79e4d0a7d4b3443fdbd1 SHA512 e96423b82812fce4621fb4467ea6f861e87d9b897b5f1a6512a860880e22a8ae1ec08ae6a4e874e3ba33456bc93c3f0e1117a2705c911056f55f6f7aaef318c5
DIST gitlab-cli-1.24.1.tar.bz2 16630772 BLAKE2B 61f618ef8cee468904457d8ac8a992ce45dd0e354296e24e4176c9f22acc26d33d9672e47542b017bdd515fb9c17bb11b9ba17cafabe66d739b9c6414a640a34 SHA512 aa92f3edbc490fe3fede9a65dda9267475f0f15a3265de31a00dc62719f7ba36d75573a7cee807e013b9218ea3497c3b6e8663bcb1a872e91a15000a2d16f386
+DIST gitlab-cli-1.25.3-deps.tar.xz 35966236 BLAKE2B 63fbcccacd6df665219d5196983cb7082424f7e87c4e58f962b73d185983a5b2a73e267fd2837a39c11eb9765f63f749a9dd61cdf901e90f0b648fd4d13faa20 SHA512 b2d73f16529ada87804ec948e7dc014c0c3309fa4ebd260e94ffd24a40f58fd1bf327c652adf74a4503bd63d685b1506b90c53230f75586107d5ec559320d47b
+DIST gitlab-cli-1.25.3.tar.bz2 16771835 BLAKE2B e36003e41649b3fc5289033892525130f9965a02095e30baf93dc7179a61ee336e12b57a3892c94259acb68717bb9fea3074985a29cf51afd28596cfcc3d864d SHA512 f916ab28d10e851a0fa389487fca4650bd0ea5b612213a26497838d45c77efcfcccbd6dc6500debedc8cd869afec0c3f0b2bf95cf3d5151ecbd0b9c793af1063
EBUILD gitlab-cli-1.24.1.ebuild 761 BLAKE2B 261e2cebd808f585e3c98f8d14b3f5286c62dce03a116c90eba4c69216683ce9dc2847efa59c14689ec00624c358ab0e40aff602d4f945b92231cb5efef3d121 SHA512 3cad1befdb9ea097c2ea0f0167756ce091753b32f94f690fcb1f1ce019d20e202a2c49a1f97dcc89b26af8e370ca22026c4543b786198aa8f86bda6e320ce3f6
+EBUILD gitlab-cli-1.25.3.ebuild 761 BLAKE2B 33652ab55e51df4696f4ff3693bd1a1f1320ed8993cb4a8d682f29be6df786b1dcced99e6b46de2ca3a7557b31ffc050875656b68098751695de2cd0d5b588bf SHA512 2b3d6b86b99f5ded06edeeb5630aa74e4c54a7f28483ab678326d7d5bef35deaea526c43a59ff8470c4c4a97c7c5368e83c268676ecb930c8e173be29819dc4a
MISC metadata.xml 328 BLAKE2B c15cee65978853695fcc911a6beb02ac29f8e82d7a82417989e497a0c014a2c5c2c22503cf2c099600e0885399496d0e7ce3b3590c8b8cfa0f6ecc6a63988d46 SHA512 4df241882ef7e722711132110271b672ef49913a92e9d70972857968e7d12a8403f5b19b5079fd78f3f08fb4aab8e615b51a6073db2c460aa2ae3ec31d8e3a28
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.25.3.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.25.3.ebuild
new file mode 100644
index 000000000000..461cbd9de31a
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.25.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=7ab3ef14820c565a9430fa0da58a491048699638
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}