summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-10 00:19:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-10 00:19:29 +0000
commita96f1a2ca235a5eb9e7c498636cd1291be76cb09 (patch)
tree9e89803a63e47477b49d98addc11305e226dad9a /dev-util/gitlab-cli
parentf20de2df8b579205c90f4970c3ad9cbb641c1a0e (diff)
gentoo auto-resync : 10:01:2023 - 00:19:28
Diffstat (limited to 'dev-util/gitlab-cli')
-rw-r--r--dev-util/gitlab-cli/Manifest4
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild32
-rw-r--r--dev-util/gitlab-cli/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/Manifest b/dev-util/gitlab-cli/Manifest
new file mode 100644
index 000000000000..333e5708adc7
--- /dev/null
+++ b/dev-util/gitlab-cli/Manifest
@@ -0,0 +1,4 @@
+DIST gitlab-cli-1.24.1-deps.tar.xz 34979684 BLAKE2B 238ac4e1a4182cc2dd83a4a49f9306e2e76635a43297df21e022b9990eb20dc0eb3b06b16d0132f1b813fc7440ddcaf6335ef77afc3c79e4d0a7d4b3443fdbd1 SHA512 e96423b82812fce4621fb4467ea6f861e87d9b897b5f1a6512a860880e22a8ae1ec08ae6a4e874e3ba33456bc93c3f0e1117a2705c911056f55f6f7aaef318c5
+DIST gitlab-cli-1.24.1.tar.bz2 16630772 BLAKE2B 61f618ef8cee468904457d8ac8a992ce45dd0e354296e24e4176c9f22acc26d33d9672e47542b017bdd515fb9c17bb11b9ba17cafabe66d739b9c6414a640a34 SHA512 aa92f3edbc490fe3fede9a65dda9267475f0f15a3265de31a00dc62719f7ba36d75573a7cee807e013b9218ea3497c3b6e8663bcb1a872e91a15000a2d16f386
+EBUILD gitlab-cli-1.24.1.ebuild 761 BLAKE2B 261e2cebd808f585e3c98f8d14b3f5286c62dce03a116c90eba4c69216683ce9dc2847efa59c14689ec00624c358ab0e40aff602d4f945b92231cb5efef3d121 SHA512 3cad1befdb9ea097c2ea0f0167756ce091753b32f94f690fcb1f1ce019d20e202a2c49a1f97dcc89b26af8e370ca22026c4543b786198aa8f86bda6e320ce3f6
+MISC metadata.xml 328 BLAKE2B c15cee65978853695fcc911a6beb02ac29f8e82d7a82417989e497a0c014a2c5c2c22503cf2c099600e0885399496d0e7ce3b3590c8b8cfa0f6ecc6a63988d46 SHA512 4df241882ef7e722711132110271b672ef49913a92e9d70972857968e7d12a8403f5b19b5079fd78f3f08fb4aab8e615b51a6073db2c460aa2ae3ec31d8e3a28
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild
new file mode 100644
index 000000000000..1a5307e23852
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=e02b30c6e3ff7801f22d37ed63850211ca0c7bb6
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}
diff --git a/dev-util/gitlab-cli/metadata.xml b/dev-util/gitlab-cli/metadata.xml
new file mode 100644
index 000000000000..1f7a2d8ea63a
--- /dev/null
+++ b/dev-util/gitlab-cli/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">gitlab-org/cli</remote-id>
+ </upstream>
+</pkgmetadata>