summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-16 22:07:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-16 22:07:44 +0100
commitc4507bfdfd706b2b1301972490fe88ac3ddbc70e (patch)
tree72500f6288cf79e445e6a5cb03337f4f64ce49db /dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild
parentaa0b5f37afc4a88422d6301d07e4e3852ddd7251 (diff)
gentoo auto-resync : 16:05:2023 - 22:07:44
Diffstat (limited to 'dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild')
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild
new file mode 100644
index 000000000000..10e6e59a82ab
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.29.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=654ae7c117d2d93fc4621b58a8cfb5388ba485a0
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}