summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-cli/gitlab-cli-1.26.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 21:51:32 +0100
commitc55c2cf7b5e5e8ce7f21c53ee7996c2ea918279d (patch)
treee8bb447a647aa737a0da2ede957972eb72e7dcd4 /dev-util/gitlab-cli/gitlab-cli-1.26.0.ebuild
parentd41bd0acd3d0cd850cdd815b12e69ee2c89c5697 (diff)
gentoo auto-resync : 28:03:2023 - 21:51:31
Diffstat (limited to 'dev-util/gitlab-cli/gitlab-cli-1.26.0.ebuild')
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.26.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.26.0.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.26.0.ebuild
new file mode 100644
index 000000000000..ff656b6ec855
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.26.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=ef363646f539ed785d29e2b07c20b5f8f00c4d45
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+S="${WORKDIR}/cli-${GIT_COMMIT}"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}