summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-ci-linter/gitlab-ci-linter-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-util/gitlab-ci-linter/gitlab-ci-linter-2.2.0.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-util/gitlab-ci-linter/gitlab-ci-linter-2.2.0.ebuild')
-rw-r--r--dev-util/gitlab-ci-linter/gitlab-ci-linter-2.2.0.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/dev-util/gitlab-ci-linter/gitlab-ci-linter-2.2.0.ebuild b/dev-util/gitlab-ci-linter/gitlab-ci-linter-2.2.0.ebuild
new file mode 100644
index 000000000000..9ea4cb00364c
--- /dev/null
+++ b/dev-util/gitlab-ci-linter/gitlab-ci-linter-2.2.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="linter for .gitlab-ci.yml files"
+HOMEPAGE="https://gitlab.com/orobardet/gitlab-ci-linter"
+
+EGO_SUM=(
+ "github.com/BurntSushi/toml v0.3.1/go.mod"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0-20190314233015-f79a8a8ca69d"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0-20190314233015-f79a8a8ca69d/go.mod"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0"
+ "github.com/cpuguy83/go-md2man/v2 v2.0.0/go.mod"
+ "github.com/fatih/color v1.9.0"
+ "github.com/fatih/color v1.9.0/go.mod"
+ "github.com/go-ini/ini v1.52.0"
+ "github.com/go-ini/ini v1.52.0/go.mod"
+ "github.com/gopherjs/gopherjs v0.0.0-20181017120253-0766667cb4d1"
+ "github.com/gopherjs/gopherjs v0.0.0-20181017120253-0766667cb4d1/go.mod"
+ "github.com/jtolds/gls v4.20.0+incompatible"
+ "github.com/jtolds/gls v4.20.0+incompatible/go.mod"
+ "github.com/mattn/go-colorable v0.1.4"
+ "github.com/mattn/go-colorable v0.1.4/go.mod"
+ "github.com/mattn/go-isatty v0.0.8/go.mod"
+ "github.com/mattn/go-isatty v0.0.11/go.mod"
+ "github.com/mattn/go-isatty v0.0.12"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/pmezard/go-difflib v1.0.0"
+ "github.com/pmezard/go-difflib v1.0.0/go.mod"
+ "github.com/russross/blackfriday/v2 v2.0.1"
+ "github.com/russross/blackfriday/v2 v2.0.1/go.mod"
+ "github.com/shurcooL/sanitized_anchor_name v1.0.0"
+ "github.com/shurcooL/sanitized_anchor_name v1.0.0/go.mod"
+ "github.com/smartystreets/assertions v0.0.0-20180927180507-b2de0cb4f26d"
+ "github.com/smartystreets/assertions v0.0.0-20180927180507-b2de0cb4f26d/go.mod"
+ "github.com/smartystreets/goconvey v1.6.4"
+ "github.com/smartystreets/goconvey v1.6.4/go.mod"
+ "github.com/urfave/cli/v2 v2.1.1"
+ "github.com/urfave/cli/v2 v2.1.1/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/net v0.0.0-20190311183353-d8887717615a"
+ "golang.org/x/net v0.0.0-20190311183353-d8887717615a/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190222072716-a9d3bda3a223/go.mod"
+ "golang.org/x/sys v0.0.0-20191026070338-33540a1f6037/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20200323222414-85ca7c5b95cd"
+ "golang.org/x/sys v0.0.0-20200323222414-85ca7c5b95cd/go.mod"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/tools v0.0.0-20190328211700-ab21143f2384"
+ "golang.org/x/tools v0.0.0-20190328211700-ab21143f2384/go.mod"
+ "gopkg.in/check.v1 v0.0.0-20161208181325-20d25e280405/go.mod"
+ "gopkg.in/ini.v1 v1.52.0"
+ "gopkg.in/ini.v1 v1.52.0/go.mod"
+ "gopkg.in/yaml.v2 v2.2.2/go.mod"
+ )
+go-module_set_globals
+SRC_URI="https://gitlab.com/orobardet/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-no-strip.patch
+)
+
+src_compile() {
+ unset LDFLAGS
+ emake
+}
+
+src_install() {
+ dobin .build/gitlab-ci-linter
+ dodoc -r CHANGELOG.md doc README.md
+}