summaryrefslogtreecommitdiff
path: root/dev-util/gitchangelog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-util/gitchangelog
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-util/gitchangelog')
-rw-r--r--dev-util/gitchangelog/Manifest3
-rw-r--r--dev-util/gitchangelog/gitchangelog-3.0.9.ebuild41
-rw-r--r--dev-util/gitchangelog/metadata.xml15
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/gitchangelog/Manifest b/dev-util/gitchangelog/Manifest
new file mode 100644
index 000000000000..d02cd886abe2
--- /dev/null
+++ b/dev-util/gitchangelog/Manifest
@@ -0,0 +1,3 @@
+DIST gitchangelog-3.0.9.tar.gz 52483 BLAKE2B 8e7fc61dee6cba6e630cb2006d5bec988ea3d7a7c1e09789b430e11d4c3d8f5e7ff7ee1231dbbcb56185c84fa9c2bbf6a353980f5a70c8a0cce51b2dce83fb5d SHA512 4e290d75455ddddb7d12d831dce973771f861d23d6b6548b8a9e24e838b0931255dfc8c9ef25765fb4f269d5cdad6bd207fbaa3626a3b24681efdbb56ad9e1b1
+EBUILD gitchangelog-3.0.9.ebuild 969 BLAKE2B 1c7d4e4cb763b38496a2dfebcc35ac94027dec4d35c194e321256f860b9b95ae03b855047f28c58a83ec31cf6c2acafbf9ae3bd19d36e884f2e5cf6600f0c34b SHA512 fdb13230e8d3c4a35edc6876de02b9936bded1c20f935db08911c20ef27270e889d9d65fd241ea6f2104317bb9a605b23333bd7d7ee9d8cdb0c61c99cb7ec8fd
+MISC metadata.xml 494 BLAKE2B 824c3efe12c8bbf8cbe59105480a1b7577bacc5de585bd885ce6880be01581686430ede68caa26dc70a48c61b01b13fe237ddc883abe7003549e52e04faa81bc SHA512 1e8116ae5af5d981512ebaff010ea44694d0563f552adadd853aaae18348f498265cdae078d2ab2753986904255b127bbff2a56dfc4b1373bd1b255a18ed00db
diff --git a/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild b/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
new file mode 100644
index 000000000000..d2e9d691c1bb
--- /dev/null
+++ b/dev-util/gitchangelog/gitchangelog-3.0.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTULS_USE_SETUPTOOLS="pyproject.toml"
+
+inherit distutils-r1
+
+DESCRIPTION="Creates a changelog from git log history"
+HOMEPAGE="https://github.com/sarnold/gitchangelog"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/gitchangelog.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/minimock[${PYTHON_USEDEP}] )
+"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/pystache[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${EPYTHON}" -m nose -sx . || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-util/gitchangelog/metadata.xml b/dev-util/gitchangelog/metadata.xml
new file mode 100644
index 000000000000..14d417cfceb2
--- /dev/null
+++ b/dev-util/gitchangelog/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+</maintainer>
+<longdescription lang="en">
+ Create a fancy changelog from git log history (in rst or md) and
+ customize your config with Python callables and regex.
+</longdescription>
+<upstream>
+ <remote-id type="github">sarnold/gitchangelog</remote-id>
+</upstream>
+</pkgmetadata>