summaryrefslogtreecommitdiff
path: root/dev-util/gertty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-02 05:22:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-02 05:22:02 +0100
commitf20a854a6189579b2cc296900c479d9b6b5b595e (patch)
tree310fb68782e96ae228c8ffe97ae3b2859a7e4a17 /dev-util/gertty
parentb7e514e2dc987a8b3e10ea8ea3d6e1d197eeb355 (diff)
gentoo auto-resync : 02:05:2023 - 05:22:02
Diffstat (limited to 'dev-util/gertty')
-rw-r--r--dev-util/gertty/Manifest3
-rw-r--r--dev-util/gertty/files/sqlalchemy-2.patch116
-rw-r--r--dev-util/gertty/gertty-9999.ebuild3
3 files changed, 121 insertions, 1 deletions
diff --git a/dev-util/gertty/Manifest b/dev-util/gertty/Manifest
index 0bf53b13d496..96fcb6dd825f 100644
--- a/dev-util/gertty/Manifest
+++ b/dev-util/gertty/Manifest
@@ -1,4 +1,5 @@
+AUX sqlalchemy-2.patch 5029 BLAKE2B 0505cf0f09c59ac32d3df59eb24075815ebf334396a7a5a7516b2e9cfc9425a1f7dbd62066ec3a67eaae3c87454d39206f176df021ec5599da955699815b4781 SHA512 4b9ce3cb4e156be81fc2080789d7bf35e76b0f459c162027788b02839827277f9313fe1aa788914ae65e8d9c5bd67e4c26aa6ae6b826ae0b3fd96e188acad003
DIST gertty-1.6.0.tar.gz 122570 BLAKE2B 8c3628f9b0b56aaff30f183a1ab0d852b8ee487927833f41b8aa61f94f8d14eaf3a8d515d5edcb3fa7dd18ca36f42a977d12790c52d6c629a720b4f29252b030 SHA512 0fe5224f5b4b06910bba0d19453ea0f273f6ea0688b9aa092e11f929b71801581f6d7cead1d64c00912ee3363b98d4b36e903fa992a7ce36f190a4f3c09375d2
EBUILD gertty-1.6.0-r1.ebuild 1117 BLAKE2B 9ac4f2dc15ae88d0f84f97b0c037754c4e9453bc2409a9b618c874815864d586c24ef51070782cc78498a8748e48d0d111e46ad34ee991d513117fb2512f124b SHA512 627893076610d349a92c12cbaea8ad03f5141e57d24a2d28b3c3f833eb6f4da778f697dfb110a79b73202bacacd9853023283024d56d8983e4bd87341e3e2a75
-EBUILD gertty-9999.ebuild 1119 BLAKE2B 6dd75d00b0f07ca77f640d6621e455015e576b256483873ef8391c7b6c61a205323b53957bff4291a225a033048ae743eef468d287727a14755d52939d4db1f5 SHA512 d2be42e38e9a14bd264dd83611edbd887bfcea126e2c4fb1b3fee2ba75504802235beb43d0f09fc7543264e692a3007056e329c68b8a8d45a182e367788fdb71
+EBUILD gertty-9999.ebuild 1244 BLAKE2B 0675e1d41cc36adfef6ea9d97acac3a61640452d060ac5c836cdc25021097e4d0d6e90abbd90dc7787d15c39be3fee03886c538f51e056dbd5c51fd690b5c2f2 SHA512 9535c9f229e4184a95791fdac47bcf08c9e28d37077fc8a970e9e87f83585463919b8b0156eb5141d8836243992987018bb3d2938ae12545d4057bd0bbd7d12b
MISC metadata.xml 380 BLAKE2B ad29f16ddaf80c092a0ade8008f0234b4c2d61b0676e3eb8ffff7055f0da28a3065de464c912b6345a94e0c189452f7826f70a924ca198a4eed8caa0c0b1dbc9 SHA512 30c0a68fffbedf4900a00bab11299c45dd65994b7e77bfa83ab7dd75f2bc0056b63e63ff2632d30b8c7bffbd4427c8a9b59ebaad3c854e1d4bdac48ffe6b330e
diff --git a/dev-util/gertty/files/sqlalchemy-2.patch b/dev-util/gertty/files/sqlalchemy-2.patch
new file mode 100644
index 000000000000..b1f8891223e9
--- /dev/null
+++ b/dev-util/gertty/files/sqlalchemy-2.patch
@@ -0,0 +1,116 @@
+From 50b3b11ef9c30d4923c82949c66dc6fe3ed0047a Mon Sep 17 00:00:00 2001
+From: Matthew Thode <mthode@mthode.org>
+Date: Tue, 11 Apr 2023 23:46:27 -0500
+Subject: [PATCH] make gertty work with sqlalchemy-2
+
+Change-Id: I80c007af86cd7102c3c75963ad5b0a051dd9b541
+Signed-off-by: Matthew Thode <mthode@mthode.org>
+---
+ gertty/db.py | 41 +++++++++++++++++++++--------------------
+ 1 file changed, 21 insertions(+), 20 deletions(-)
+
+diff --git a/gertty/db.py b/gertty/db.py
+index 92cc278..82cffaa 100644
+--- a/gertty/db.py
++++ b/gertty/db.py
+@@ -25,11 +25,12 @@ import six
+ import sqlalchemy
+ from sqlalchemy import create_engine, MetaData, Table, Column, Integer, String, Boolean, DateTime, Text, UniqueConstraint
+ from sqlalchemy.schema import ForeignKey
+-from sqlalchemy.orm import mapper, sessionmaker, relationship, scoped_session, joinedload
++from sqlalchemy.orm import registry, sessionmaker, relationship, scoped_session, joinedload
+ from sqlalchemy.orm.session import Session
+ from sqlalchemy.sql import exists
+ from sqlalchemy.sql.expression import and_
+
++mapper = registry()
+ metadata = MetaData()
+ project_table = Table(
+ 'project', metadata,
+@@ -713,8 +714,8 @@ class Check(object):
+ self.created = created
+ self.updated = updated
+
+-mapper(Account, account_table)
+-mapper(Project, project_table, properties=dict(
++mapper.map_imperatively(Account, account_table)
++mapper.map_imperatively(Project, project_table, properties=dict(
+ branches=relationship(Branch, backref='project',
+ order_by=branch_table.c.name,
+ cascade='all, delete-orphan'),
+@@ -740,16 +741,16 @@ mapper(Project, project_table, properties=dict(
+ order_by=change_table.c.number,
+ ),
+ ))
+-mapper(Branch, branch_table)
+-mapper(Topic, topic_table, properties=dict(
++mapper.map_imperatively(Branch, branch_table)
++mapper.map_imperatively(Topic, topic_table, properties=dict(
+ projects=relationship(Project,
+ secondary=project_topic_table,
+ order_by=project_table.c.name,
+ viewonly=True),
+ project_topics=relationship(ProjectTopic),
+ ))
+-mapper(ProjectTopic, project_topic_table)
+-mapper(Change, change_table, properties=dict(
++mapper.map_imperatively(ProjectTopic, project_topic_table)
++mapper.map_imperatively(Change, change_table, properties=dict(
+ owner=relationship(Account),
+ conflicts1=relationship(Change,
+ secondary=change_conflict_table,
+@@ -787,7 +788,7 @@ mapper(Change, change_table, properties=dict(
+ order_by=(approval_table.c.category,
+ approval_table.c.value))
+ ))
+-mapper(Revision, revision_table, properties=dict(
++mapper.map_imperatively(Revision, revision_table, properties=dict(
+ messages=relationship(Message, backref='revision',
+ cascade='all, delete-orphan'),
+ files=relationship(File, backref='revision',
+@@ -798,9 +799,9 @@ mapper(Revision, revision_table, properties=dict(
+ cascade='all, delete-orphan'),
+
+ ))
+-mapper(Message, message_table, properties=dict(
++mapper.map_imperatively(Message, message_table, properties=dict(
+ author=relationship(Account)))
+-mapper(File, file_table, properties=dict(
++mapper.map_imperatively(File, file_table, properties=dict(
+ comments=relationship(Comment, backref='file',
+ order_by=(comment_table.c.line,
+ comment_table.c.created),
+@@ -812,20 +813,20 @@ mapper(File, file_table, properties=dict(
+ comment_table.c.created)),
+ ))
+
+-mapper(Comment, comment_table, properties=dict(
++mapper.map_imperatively(Comment, comment_table, properties=dict(
+ author=relationship(Account)))
+-mapper(Label, label_table)
+-mapper(PermittedLabel, permitted_label_table)
+-mapper(Approval, approval_table, properties=dict(
++mapper.map_imperatively(Label, label_table)
++mapper.map_imperatively(PermittedLabel, permitted_label_table)
++mapper.map_imperatively(Approval, approval_table, properties=dict(
+ reviewer=relationship(Account)))
+-mapper(PendingCherryPick, pending_cherry_pick_table)
+-mapper(SyncQuery, sync_query_table)
+-mapper(Hashtag, hashtag_table)
+-mapper(Server, server_table, properties=dict(
++mapper.map_imperatively(PendingCherryPick, pending_cherry_pick_table)
++mapper.map_imperatively(SyncQuery, sync_query_table)
++mapper.map_imperatively(Hashtag, hashtag_table)
++mapper.map_imperatively(Server, server_table, properties=dict(
+ own_account=relationship(Account)
+ ))
+-mapper(Checker, checker_table)
+-mapper(Check, check_table, properties=dict(
++mapper.map_imperatively(Checker, checker_table)
++mapper.map_imperatively(Check, check_table, properties=dict(
+ checker=relationship(Checker)))
+
+
+--
+2.39.2
+
diff --git a/dev-util/gertty/gertty-9999.ebuild b/dev-util/gertty/gertty-9999.ebuild
index 99f28ea8c61b..1c4077d597a8 100644
--- a/dev-util/gertty/gertty-9999.ebuild
+++ b/dev-util/gertty/gertty-9999.ebuild
@@ -21,6 +21,9 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
+# needed til upstream merges https://review.opendev.org/c/ttygroup/gertty/+/880123
+PATCHES="${FILESDIR}/sqlalchemy-2.patch"
+
DEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/pbr-0.11[${PYTHON_USEDEP}]