summaryrefslogtreecommitdiff
path: root/dev-util/gengetopt/gengetopt-2.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-08 09:04:53 +0100
commit73c318acdaf6f8309d68bd266051e6dd1f1bd787 (patch)
tree2878053f3e7faed19a1f82c733d3bd29df69991e /dev-util/gengetopt/gengetopt-2.23.ebuild
parent2018227e9344edb9da15fc6a4a8298086cc2aa77 (diff)
gentoo resync : 08.06.2019
Diffstat (limited to 'dev-util/gengetopt/gengetopt-2.23.ebuild')
-rw-r--r--dev-util/gengetopt/gengetopt-2.23.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/gengetopt/gengetopt-2.23.ebuild b/dev-util/gengetopt/gengetopt-2.23.ebuild
new file mode 100644
index 000000000000..23b2c1fa86df
--- /dev/null
+++ b/dev-util/gengetopt/gengetopt-2.23.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A tool to write command line option parsing code for C programs"
+HOMEPAGE="https://www.gnu.org/software/gengetopt/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.22.6-docdirs.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' -i configure.ac || die
+ sed -e '/gengetoptdoc_DATA/d' -i Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}