summaryrefslogtreecommitdiff
path: root/dev-util/geany-plugins/geany-plugins-1.38-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 08:42:41 +0100
commit0fcaac21e786bd7911b1e8f436cd885c5e2f6437 (patch)
treeba392915815492b0ce486fc0e3ad5afb4a849b6f /dev-util/geany-plugins/geany-plugins-1.38-r5.ebuild
parente30edd47e1804bf3ed1ea7be2eac67f4b8cd9f38 (diff)
gentoo auto-resync : 27:10:2023 - 08:42:41
Diffstat (limited to 'dev-util/geany-plugins/geany-plugins-1.38-r5.ebuild')
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.38-r5.ebuild129
1 files changed, 0 insertions, 129 deletions
diff --git a/dev-util/geany-plugins/geany-plugins-1.38-r5.ebuild b/dev-util/geany-plugins/geany-plugins-1.38-r5.ebuild
deleted file mode 100644
index 7f84f12c63f3..000000000000
--- a/dev-util/geany-plugins/geany-plugins-1.38-r5.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-1 )
-LUA_REQ_USE="deprecated"
-
-inherit flag-o-matic lua-single
-
-DESCRIPTION="A collection of different plugins for Geany"
-HOMEPAGE="https://plugins.geany.org"
-SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 ~riscv ~sparc x86"
-
-IUSE="ctags debugger enchant git gpg gtkspell lua markdown nls pretty-printer scope soup workbench"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
-
-DEPEND="
- dev-libs/glib:2
- >=dev-util/geany-1.37[-gtk2(-)]
- x11-libs/gtk+:3
- ctags? ( dev-util/ctags )
- debugger? ( x11-libs/vte:2.91 )
- enchant? ( app-text/enchant:= )
- git? ( dev-libs/libgit2:= )
- gpg? ( app-crypt/gpgme:= )
- gtkspell? ( app-text/gtkspell:3= )
- lua? ( ${LUA_DEPS} )
- markdown? (
- app-text/discount:=
- net-libs/webkit-gtk:4
- )
- pretty-printer? ( dev-libs/libxml2:2 )
- scope? ( x11-libs/vte:2.91 )
- soup? ( net-libs/libsoup:2.4 )
- workbench? ( dev-libs/libgit2:= )
-"
-RDEPEND="${DEPEND}
- scope? ( sys-devel/gdb )
-"
-BDEPEND="virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-PATCHES=( "${FILESDIR}/${P}-libgit2-1.4.patch" )
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_configure() {
- # -DLUA_COMPAT_OPENLIB=1 is required to enable the
- # deprecated (in 5.1) luaL_openlib API (#878529)
- use lua_single_target_lua5-1 && append-cppflags -DLUA_COMPAT_OPENLIB=1
-
- local myeconfargs=(
- --disable-cppcheck
- --disable-extra-c-warnings
- $(use_enable nls)
- --enable-utilslib
- # Plugins
- --enable-addons
- --enable-autoclose
- --enable-automark
- --enable-codenav
- --enable-commander
- --enable-defineformat
- --enable-geanydoc
- --enable-geanyextrasel
- --enable-geanyinsertnum
- --enable-geanymacro
- --enable-geanyminiscript
- --enable-geanynumberedbookmarks
- --enable-geanyprj
- --enable-geanyvc $(use_enable gtkspell)
- --enable-keyrecord
- --enable-latex
- --enable-lineoperations
- --enable-lipsum
- --enable-overview
- --enable-pairtaghighlighter
- --enable-pohelper
- --enable-projectorganizer
- --enable-sendmail
- --enable-shiftcolumn
- --enable-tableconvert
- --enable-treebrowser
- --enable-vimode
- --enable-xmlsnippets
- $(use_enable debugger)
- $(use_enable ctags geanyctags)
- $(use_enable lua geanylua)
- $(use_enable gpg geanypg)
- $(use_enable soup geniuspaste)
- $(use_enable git gitchangebar)
- $(use_enable markdown) --disable-peg-markdown # using app-text/discount instead
- $(use_enable pretty-printer)
- $(use_enable scope)
- $(use_enable enchant spellcheck)
- # Having updatechecker… when you’re using a package manager?
- $(use_enable soup updatechecker)
- $(use_enable workbench)
- # GeanyGenDoc requires ctpl which isn’t yet in portage
- --disable-geanygendoc
- # Require obsolete and vulnerable webkit-gtk versions
- --disable-devhelp
- --disable-webhelper
- # GTK 2 only
- --disable-geanypy
- --disable-multiterm
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- find "${D}" -name '*.la' -delete || die
-
- # make installs all translations if LINGUAS is empty
- if [[ -z "${LINGUAS-x}" ]]; then
- rm -r "${ED}/usr/share/locale/" || die
- fi
-}