summaryrefslogtreecommitdiff
path: root/dev-util/fuzz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-14 00:13:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-14 00:13:14 +0000
commit4fda045f90a4e301329bddb766e2e12a0b4401de (patch)
tree1d486767bfd9de15d6c11d341408385eb7f7debe /dev-util/fuzz
parent965058196f44550f3bc491dd85064071e085b776 (diff)
gentoo auto-resync : 14:02:2025 - 00:13:14
Diffstat (limited to 'dev-util/fuzz')
-rw-r--r--dev-util/fuzz/Manifest3
-rw-r--r--dev-util/fuzz/files/fuzz-0.6-musl.patch34
-rw-r--r--dev-util/fuzz/fuzz-0.6-r4.ebuild (renamed from dev-util/fuzz/fuzz-0.6-r3.ebuild)7
3 files changed, 41 insertions, 3 deletions
diff --git a/dev-util/fuzz/Manifest b/dev-util/fuzz/Manifest
index d2144a0f7533..483049ecac7b 100644
--- a/dev-util/fuzz/Manifest
+++ b/dev-util/fuzz/Manifest
@@ -1,4 +1,5 @@
+AUX fuzz-0.6-musl.patch 1273 BLAKE2B 6c59fd5a194d2d7c1ce1c7f7f512e00f1d1f1265575229f16704746dfe23dc080da7f558d16ff37a669471ea541f069526f0a27e6900aae72334886e9922ab6b SHA512 7f03b0a2562ae40b93eb307b14854b0837b2efdd029324a73250802d575b9da929ba3691e95e0429e13807330fe9b57cda983dcabce4a97e1e8b73f6ffe92805
DIST fuzz-0.6.tar.gz 54431 BLAKE2B 8f9652fbcf13038e066d9eff5bb803a9bb76ded9c9f18f9c39981e40530a8fa2ef2fa1aa39e6196908046e7c3dc9acab8ef2adea9a9c8ef824635b1c02aae248 SHA512 87a9b103bb37c91937e2bd4667a33f3792c464f8464fe1f35b022d9c01a13255c7228ab80ce0bfac4ccfdab9a25238a5e1add00e9380cbeb24f95b686d18151b
DIST fuzz_0.6-7.3.diff.gz 3004 BLAKE2B fbbceb60b58e973ceae6485f26297bd843261db8d80d0988ec08eaf275758d32d5e3c992999543db1e3f1cc546dd881f8fa19b6c027bdb79dc3dad84b8f77ae9 SHA512 aef080a908269d44536071bb6d4a91560d7f357fb2145fc0d0369ea5997fa6a5c1b13b3fc673c370a61add5c76f40df3501f5103f2ac35ddce9662c9345e20af
-EBUILD fuzz-0.6-r3.ebuild 735 BLAKE2B 0689c7e9416037eb4671bd2acd23ecfcc7efef61eb8d4c1f051918d8d46e55448310fe14c46caa905c2854f8b827991ad015fbc09ef48abe14b2b464c90ebc7f SHA512 21f8b58d7e85d5ca9b97156f9efc05554cde9566e79c88930ff3dfb2bc23b62ebc0a0e9a4ecb1d47009a2b55265a76c6ebbd4d3a375859bf4d10ded36b384379
+EBUILD fuzz-0.6-r4.ebuild 771 BLAKE2B 39afc1e2a7f4ceec84df8644411cd2fdea8fe0a0b82e859c1f3edac742a85371c7963cf9ce99bfb185546dcf9c750af9bcb5c6aa89b756a2fbf62be7b8b01985 SHA512 17823128d272ad5733fe54a0d4582a01d19cff927374e1603ba5c011c54872fd7aa6bf79f1e91e212698852208959b6afb9a3d9590eb5bd749dbab9e1cd71556
MISC metadata.xml 301 BLAKE2B 61c39ed1a6560b4e9a9970fcf226009c5217e57c9d942461b7daa67da0a919cd5dbb34c78da28254480e92fdf4fda1e96758fab40abd3db1a2276cced1ff5850 SHA512 4dcea2d5fb529eb59f4b9d2ce34d83be0f455ddd1215beef09f74a56d8fe3274c7cf0a40dcff11f4e0509bf27dbf928d14b0d08d2e47a9226af4ba5391b3a635
diff --git a/dev-util/fuzz/files/fuzz-0.6-musl.patch b/dev-util/fuzz/files/fuzz-0.6-musl.patch
new file mode 100644
index 000000000000..6783e008a8a6
--- /dev/null
+++ b/dev-util/fuzz/files/fuzz-0.6-musl.patch
@@ -0,0 +1,34 @@
+Fix missing include on musl, as strcmp is not transitively included
+Remove arg-less declaration for non-glibc case: we have POSIX here,
+getopt has same prototype in glibc and in musl
+https://bugs.gentoo.org/934059
+https://bugs.gentoo.org/944111
+--- a/getopt.c
++++ b/getopt.c
+@@ -43,6 +43,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C
+--- a/getopt.h
++++ b/getopt.h
+@@ -99,14 +99,12 @@
+ #define optional_argument 2
+
+ #if defined (__STDC__) && __STDC__
+-#ifdef __GNU_LIBRARY__
+ /* Many other libraries have conflicting prototypes for getopt, with
+ differences in the consts, in stdlib.h. To avoid compilation
+ errors, only prototype getopt for the GNU C library. */
++/* But in Gentoo we have glibc and musl, and they have same POSIX
++ definition */
+ extern int getopt (int argc, char *const *argv, const char *shortopts);
+-#else /* not __GNU_LIBRARY__ */
+-extern int getopt ();
+-#endif /* __GNU_LIBRARY__ */
+ extern int getopt_long (int argc, char *const *argv, const char *shortopts,
+ const struct option *longopts, int *longind);
+ extern int getopt_long_only (int argc, char *const *argv,
diff --git a/dev-util/fuzz/fuzz-0.6-r3.ebuild b/dev-util/fuzz/fuzz-0.6-r4.ebuild
index b5e826d55c10..152195a2ab69 100644
--- a/dev-util/fuzz/fuzz-0.6-r3.ebuild
+++ b/dev-util/fuzz/fuzz-0.6-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,7 +21,10 @@ KEYWORDS="~amd64 ~x86"
DEPEND="sys-libs/readline:="
RDEPEND="${DEPEND}"
-PATCHES=( "${WORKDIR}"/${DEB_P}-${DEB_PR}.diff )
+PATCHES=(
+ "${WORKDIR}"/"${DEB_P}-${DEB_PR}.diff"
+ "${FILESDIR}"/"${P}-musl.patch"
+)
src_prepare() {
default