summaryrefslogtreecommitdiff
path: root/dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild')
-rw-r--r--dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild b/dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild
new file mode 100644
index 000000000000..a8cf96c8ab2d
--- /dev/null
+++ b/dev-util/ftjam/ftjam-2.5.3_rc2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV=$(delete_version_separator _)
+
+DESCRIPTION="Jam is a powerful alternative to make. FTJam is a 100% compatible enhanced Jam implementation"
+HOMEPAGE="http://freetype.sourceforge.net/jam/index.html"
+SRC_URI="http://david.freetype.org/jam/ftjam-${MY_PV}.tar.bz2"
+
+LICENSE="perforce GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="!dev-util/jam
+ sys-devel/bison"
+RDEPEND="!dev-util/jam"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.5.3-nostrip.patch
+ epatch "${FILESDIR}"/${PN}-2.5.3-i-hate-yacc.patch
+ epatch "${FILESDIR}"/${PN}-2.5.3-false-flags.patch
+# epatch "${FILESDIR}"/${PN}-2.5.3-debug-commandline.patch # development only
+}
+
+src_compile() {
+ tc-export CC
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README README.ORG CHANGES INSTALL RELNOTES
+ dohtml Jam.html Jambase.html Jamfile.html
+}