summaryrefslogtreecommitdiff
path: root/dev-util/fq/fq-0.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 14:02:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 14:02:21 +0000
commit9aefa814d833d6bdd1bdbc7d0f44d5680c9beaa8 (patch)
treeb70c1d27324b2ed33e5688d4a21f6c5195032ecf /dev-util/fq/fq-0.2.0-r1.ebuild
parent1cf3f23200484257eaf7d863e323e7e9aee98d2b (diff)
gentoo auto-resync : 24:12:2022 - 14:02:21
Diffstat (limited to 'dev-util/fq/fq-0.2.0-r1.ebuild')
-rw-r--r--dev-util/fq/fq-0.2.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/fq/fq-0.2.0-r1.ebuild b/dev-util/fq/fq-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..c4bb233a488d
--- /dev/null
+++ b/dev-util/fq/fq-0.2.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Tool for working with binary data (app-misc/jq for binary formats)"
+HOMEPAGE="https://github.com/wader/fq"
+SRC_URI="https://github.com/wader/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-tcltk/expect )"
+
+src_prepare() {
+ default
+
+ # https://github.com/wader/fq/issues/494
+ sed -i -e '/test_repl.exp/d' Makefile || die
+ # Don't unconditionally (and therefore twice) build tests
+ # TODO: upstream
+ sed -i -e 's/all: test fq/all: fq/' Makefile || die
+}
+
+src_compile() {
+ # Avoid -s being set in Makefile (stripping)
+ export GO_BUILD_LDFLAGS="-w"
+
+ default
+}
+
+src_install() {
+ einstalldocs
+
+ dobin fq
+}