summaryrefslogtreecommitdiff
path: root/dev-util/fhist/fhist-1.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/fhist/fhist-1.21.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/fhist/fhist-1.21.ebuild')
-rw-r--r--dev-util/fhist/fhist-1.21.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/fhist/fhist-1.21.ebuild b/dev-util/fhist/fhist-1.21.ebuild
new file mode 100644
index 000000000000..1f783dcb8d3a
--- /dev/null
+++ b/dev-util/fhist/fhist-1.21.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="File history and comparison tools"
+HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
+SRC_URI="http://fhist.sourceforge.net/${P}.D001.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libexplain
+ sys-devel/gettext
+ sys-apps/groff"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ test? ( app-arch/sharutils )"
+
+src_prepare() {
+ MAKEOPTS+=" -j1"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ append-cflags -fgnu89-inline
+}