summaryrefslogtreecommitdiff
path: root/dev-util/fhist/fhist-1.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/fhist/fhist-1.16.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/fhist/fhist-1.16.ebuild')
-rw-r--r--dev-util/fhist/fhist-1.16.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/fhist/fhist-1.16.ebuild b/dev-util/fhist/fhist-1.16.ebuild
new file mode 100644
index 000000000000..1bcd65423a17
--- /dev/null
+++ b/dev-util/fhist/fhist-1.16.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="File history and comparison tools"
+HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
+SRC_URI="http://fhist.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc x86"
+IUSE="test"
+
+RDEPEND="sys-devel/gettext
+ sys-apps/groff"
+DEPEND="${RDEPEND}
+ test? ( app-arch/sharutils )
+ sys-devel/bison"
+
+MAKEOPTS+=" -j1"
+
+src_compile() {
+ econf
+ emake || die "emake failed"
+}
+
+src_test() {
+ emake sure || die "src_test failed"
+}
+
+src_install () {
+ emake \
+ RPM_BUILD_ROOT="${D}" \
+ NLSDIR="${D}/usr/share/locale" \
+ install || die "make install failed"
+
+ dodoc lib/en/*.txt || die
+ dodoc lib/en/*.ps || die
+
+ # remove duplicate docs etc.
+ rm -r "${D}"/usr/share/fhist
+
+ dodoc MANIFEST README || die
+}