summaryrefslogtreecommitdiff
path: root/dev-util/eric/eric-19.11-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-util/eric/eric-19.11-r1.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-util/eric/eric-19.11-r1.ebuild')
-rw-r--r--dev-util/eric/eric-19.11-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/eric/eric-19.11-r1.ebuild b/dev-util/eric/eric-19.11-r1.ebuild
new file mode 100644
index 000000000000..bb8cee447042
--- /dev/null
+++ b/dev-util/eric/eric-19.11-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="sqlite,xml"
+inherit python-single-r1 xdg
+
+MY_P=${PN}6-${PV}
+
+DESCRIPTION="A full featured Python IDE using PyQt and QScintilla"
+HOMEPAGE="https://eric-ide.python-projects.org/"
+SRC_URI="mirror://sourceforge/eric-ide/${PN}6/stable/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="6"
+KEYWORDS="~amd64 ~x86"
+IUSE="spell"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/PyQt5-5.12[gui,help,network,printsupport,sql,svg,widgets,${PYTHON_MULTI_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+ dev-python/qscintilla-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/sip[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/chardet-3.0.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygments-2.3.1[${PYTHON_MULTI_USEDEP}]
+ spell? ( dev-python/pyenchant[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( eric/docs/{changelog,README.rst,README-eric6-doc.rst,README-passive-debugging.rst,THANKS} )
+
+src_prepare() {
+ default
+
+ # Delete internal copies of dev-python/chardet and dev-python/pygments
+ rm -fr eric/eric6/ThirdParty/{CharDet,Pygments} || die
+}
+
+src_install() {
+ yes n | "${PYTHON}" install.py \
+ -b "${EPREFIX}/usr/bin" \
+ -d "$(python_get_sitedir)" \
+ -i "${D}" \
+ -c \
+ -z \
+ || die
+
+ python_optimize
+ einstalldocs
+}