summaryrefslogtreecommitdiff
path: root/dev-util/elfkickers/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-util/elfkickers/files
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-util/elfkickers/files')
-rw-r--r--dev-util/elfkickers/files/elfkickers-3.1-AR.patch23
-rw-r--r--dev-util/elfkickers/files/elfkickers-3.1-CC.patch12
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/elfkickers/files/elfkickers-3.1-AR.patch b/dev-util/elfkickers/files/elfkickers-3.1-AR.patch
new file mode 100644
index 000000000000..6b5100c06eee
--- /dev/null
+++ b/dev-util/elfkickers/files/elfkickers-3.1-AR.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/724258
+--- a/ebfc/Makefile
++++ b/ebfc/Makefile
+@@ -10,7 +10,7 @@ brainfuck.o: brainfuck.c elfparts.h ebfc.h
+
+ libelfparts.a: elfparts.o ehdr.o phdrtab.o shdrtab.o progbits.o \
+ strtab.o symtab.o hash.o rel.o got.o dynamic.o
+- ar crs libelfparts.a $^
++ $(AR) crs libelfparts.a $^
+
+ elfparts.o: elfparts.c elfparts.h gen.h
+ ehdr.o: ehdr.c elfparts.h gen.h
+--- a/elfrw/Makefile
++++ b/elfrw/Makefile
+@@ -6,7 +6,7 @@ LIBOBJS = elfrw.o elfrw_dyn.o elfrw_ehdr.o elfrw_phdr.o elfrw_rel.o \
+ elfrw_shdr.o elfrw_sym.o elfrw_ver.o
+
+ libelfrw.a: $(LIBOBJS)
+- ar crs $@ $^
++ $(AR) crs $@ $^
+
+ elfrw.o: elfrw.c elfrw.h elfrw_int.h
+ elfrw_dyn.o: elfrw_dyn.c elfrw_int.h
diff --git a/dev-util/elfkickers/files/elfkickers-3.1-CC.patch b/dev-util/elfkickers/files/elfkickers-3.1-CC.patch
new file mode 100644
index 000000000000..b1541d5cb179
--- /dev/null
+++ b/dev-util/elfkickers/files/elfkickers-3.1-CC.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/790611
+--- a/elftoc/Makefile
++++ b/elftoc/Makefile
+@@ -30,7 +30,7 @@ out.o : out.c out.h gen.h readelf.h pieces.h address.h shdrtab.h \
+ elftoc.o : elftoc.c gen.h readelf.h pieces.h address.h outbase.h out.h
+
+ elfnames.c: mknames
+- echo '#include <elf.h>' | gcc -E -dM -xc /dev/stdin | ./$^ $@
++ echo '#include <elf.h>' | $(CC) -E -dM -xc /dev/stdin | ./$^ $@
+
+ mknames: mknames.o
+ mknames.o: mknames.c