summaryrefslogtreecommitdiff
path: root/dev-util/dwdiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/dwdiff
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/dwdiff')
-rw-r--r--dev-util/dwdiff/Manifest6
-rw-r--r--dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild47
-rw-r--r--dev-util/dwdiff/dwdiff-2.1.0.ebuild40
-rw-r--r--dev-util/dwdiff/dwdiff-2.1.1.ebuild47
-rw-r--r--dev-util/dwdiff/metadata.xml7
5 files changed, 147 insertions, 0 deletions
diff --git a/dev-util/dwdiff/Manifest b/dev-util/dwdiff/Manifest
new file mode 100644
index 000000000000..38184e69e03b
--- /dev/null
+++ b/dev-util/dwdiff/Manifest
@@ -0,0 +1,6 @@
+DIST dwdiff-2.1.0.tar.bz2 79224 BLAKE2B a201c300532757d293bbcdc61f91d81e3a2dcbc4847540bae278be561535b7ef2b6a191e2946b8af941f6550168893a17365e3020771a4468387567c4b3452f3 SHA512 63e5ea3ae510c84fa2353da55bbc3cfac3a3753e1cebfb42c387218289a5e19d8e68af663181720a55eca05e49ef075db7d5dafda9dc4d57b9af503553ae9021
+DIST dwdiff-2.1.1.tar.bz2 79628 BLAKE2B eb024d9c0eff18de9eee4a0fcf2d6a9ef6b049286ebb7f9715ddf18d920cacaab2738f04607b358be784f9d3e1c25f279ede620d412fad026f3280b9f8ee471f SHA512 b3392ef01c0701ea7738f1b539dab81727735e5de8ea77b56feae4e2f64dbda0155b479d7be0eedb65fc56ebc8d1a22c1ca67075abdec54205ad9c305b3751b7
+EBUILD dwdiff-2.1.0-r1.ebuild 832 BLAKE2B 0299a22120d753fc90df2c4237e8297cafabf916b491f85679f269da193eae89450d750b80ba32684889e5eb24cd817c3290072e56d7853fe25671460a9427e9 SHA512 9f27bae383dc6d51cf602ab6e0ddab3d31c125fadd3755e207eb7c62979b0bf0a1843e840c5fd2ea0eff209aea124e54b85f82b645311cfa0b71c9a2b1fbac73
+EBUILD dwdiff-2.1.0.ebuild 830 BLAKE2B 0f80d0d578d0ad1d2fb0c565ddb384bda81878f94bacd5b398b983b48c8ed003411748e104b926dd03f6ef2d01bb7fa9fcb2f56816117f79cbcee638a42d56a9 SHA512 eff5be39b231c56c647f5823f9c3c897e21718ef1ddef5e5a85b0cab43c34d15f69b81ec64b6f694c2f4228435b9098192bfc666766d2cfa1acf3742ec1671de
+EBUILD dwdiff-2.1.1.ebuild 832 BLAKE2B 0299a22120d753fc90df2c4237e8297cafabf916b491f85679f269da193eae89450d750b80ba32684889e5eb24cd817c3290072e56d7853fe25671460a9427e9 SHA512 9f27bae383dc6d51cf602ab6e0ddab3d31c125fadd3755e207eb7c62979b0bf0a1843e840c5fd2ea0eff209aea124e54b85f82b645311cfa0b71c9a2b1fbac73
+MISC metadata.xml 220 BLAKE2B eabf3517ba7e5b67320254eeb2b07adf1dbe0c3432b693973bc25a3e3dc8ed160b7313f9f8ae64d994ac272487b785f33202d9640bb5a7ace9f56ceb42978a19 SHA512 1db105eebacb6c7d44fd17746981e6e24badb2e81327410aa935a7603379cfcc8f3cf27dcf4e9d870cea2f73f6a15cf052e3e785205095ea9a93d72980ff71cc
diff --git a/dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild b/dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..b549a993acad
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-2.1.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="diff-like program operating at word level instead of line level"
+HOMEPAGE="https://os.ghalkes.nl/dwdiff.html"
+SRC_URI="https://os.ghalkes.nl/dist/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+
+CDEPEND="dev-libs/icu:="
+
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/diffutils"
+
+DEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
+}
diff --git a/dev-util/dwdiff/dwdiff-2.1.0.ebuild b/dev-util/dwdiff/dwdiff-2.1.0.ebuild
new file mode 100644
index 000000000000..acd2c98c7343
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-2.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="diff-like program operating at word level instead of line level"
+HOMEPAGE="https://os.ghalkes.nl/dwdiff.html"
+SRC_URI="https://os.ghalkes.nl/dist/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+COMMON_DEPEND="dev-libs/icu:="
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/diffutils"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext) || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
+}
diff --git a/dev-util/dwdiff/dwdiff-2.1.1.ebuild b/dev-util/dwdiff/dwdiff-2.1.1.ebuild
new file mode 100644
index 000000000000..b549a993acad
--- /dev/null
+++ b/dev-util/dwdiff/dwdiff-2.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="diff-like program operating at word level instead of line level"
+HOMEPAGE="https://os.ghalkes.nl/dwdiff.html"
+SRC_URI="https://os.ghalkes.nl/dist/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+
+CDEPEND="dev-libs/icu:="
+
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/diffutils"
+
+DEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/INSTALL/s:COPYING::' \
+ Makefile.in || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ $(use_with nls gettext)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
+}
diff --git a/dev-util/dwdiff/metadata.xml b/dev-util/dwdiff/metadata.xml
new file mode 100644
index 000000000000..294c350c6960
--- /dev/null
+++ b/dev-util/dwdiff/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>