summaryrefslogtreecommitdiff
path: root/dev-util/dropwatch/dropwatch-1.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-util/dropwatch/dropwatch-1.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-util/dropwatch/dropwatch-1.4-r1.ebuild')
-rw-r--r--dev-util/dropwatch/dropwatch-1.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/dropwatch/dropwatch-1.4-r1.ebuild b/dev-util/dropwatch/dropwatch-1.4-r1.ebuild
new file mode 100644
index 000000000000..341fd711b330
--- /dev/null
+++ b/dev-util/dropwatch/dropwatch-1.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="A utility to interface to the kernel to monitor for dropped network packets"
+HOMEPAGE="https://fedorahosted.org/dropwatch/"
+SRC_URI="https://fedorahosted.org/releases/d/r/dropwatch/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/libnl:3
+ sys-libs/binutils-libs
+ sys-libs/readline:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NET_DROP_MONITOR"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-binutils-2.23.patch"
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" -C src
+}
+
+src_install() {
+ dobin "src/${PN}"
+ doman "doc/${PN}.1"
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "Ensure that 'drop_monitor' kernel module is loaded before running ${PN}"
+}