summaryrefslogtreecommitdiff
path: root/dev-util/drone/drone-2.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-09 21:30:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-09 21:30:54 +0100
commit8e5dcbcd9c97dcecc17992eff0e8d01e5c83ade2 (patch)
tree72b9af89b84e219b09772e3bf824abbc801ad0e0 /dev-util/drone/drone-2.18.0.ebuild
parenta2740fd9a512436fd84baef922a0a24c4b7417d9 (diff)
gentoo auto-resync : 09:08:2023 - 21:30:54
Diffstat (limited to 'dev-util/drone/drone-2.18.0.ebuild')
-rw-r--r--dev-util/drone/drone-2.18.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/drone/drone-2.18.0.ebuild b/dev-util/drone/drone-2.18.0.ebuild
new file mode 100644
index 000000000000..6f45d08d86b7
--- /dev/null
+++ b/dev-util/drone/drone-2.18.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="A Continuous Delivery platform built on Docker, written in Go"
+HOMEPAGE="https://github.com/drone/drone"
+SRC_URI="https://github.com/drone/drone/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="acct-group/drone
+ acct-user/drone"
+ RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_compile() {
+ ego build -ldflags "-extldflags \"-static\"" \
+ ./cmd/drone-server
+}
+
+src_install() {
+ dobin drone-server
+ dodoc CHANGELOG.md HISTORY.md
+ insinto /etc
+ doins "${FILESDIR}"/drone-server.conf
+ newinitd "${FILESDIR}"/drone-server.initd drone-server
+ systemd_dounit "${FILESDIR}"/drone-server.service
+ keepdir /var/log/drone /var/lib/drone
+ fowners -R ${PN}:${PN} /var/log/drone /var/lib/drone
+}