summaryrefslogtreecommitdiff
path: root/dev-util/drone-cli/drone-cli-1.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-util/drone-cli/drone-cli-1.1.4.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-util/drone-cli/drone-cli-1.1.4.ebuild')
-rw-r--r--dev-util/drone-cli/drone-cli-1.1.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/drone-cli/drone-cli-1.1.4.ebuild b/dev-util/drone-cli/drone-cli-1.1.4.ebuild
new file mode 100644
index 000000000000..ca7f0b0fdc7f
--- /dev/null
+++ b/dev-util/drone-cli/drone-cli-1.1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/drone/drone-cli"
+
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Command-line interface for Drone"
+HOMEPAGE="https://github.com/drone/drone-cli"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="!!<dev-util/drone-0.7"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install -ldflags "-X main.version=${PV}" ${EGO_PN}/drone || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/drone
+ dodoc src/${EGO_PN}/README.md
+}