summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 11:33:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 11:33:33 +0100
commitd2e43b44e8855b7ee7b79782358dee45099efccc (patch)
treeb6dd4c6cf2a46f31df970692a4aed40056dff35e /dev-util/diffoscope
parent1a256280f70812d1ae23f0ce2a2569291b6609da (diff)
gentoo auto-resync : 25:09:2022 - 11:33:33
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-222.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 7bf7fe2547b6..219967ef5178 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-219.tar.gz 2711533 BLAKE2B 1b244a36ca2622244fb1f11f8fc895680bd1d77b544421e5e2c3662294fdf8e7efe3b67e370a83089c180f3c8563562847cc8b09bec85426e1b05f340575b724 SHA512 615b82cbd2b1a8bcdfae4274c051e4be52fb8ea90c5e56b041dd1d8c520c759d09cd4c080b31154257828316f7b4c0ac79cf0b1e09d762271ce01ffde353ee7a
DIST diffoscope-221.tar.gz 3145331 BLAKE2B 76369a7719f9a256ca61cc097bc439c5ef267370b78b5e25c466f351fc262b6a9a18f2f82d88ae86fd382a11900c4350ff79c6217c53df42ad56706ee58fa42b SHA512 145390374378f699f7689af0e35897bc9d75cd805722f0db66e689135186eb43def17ec5aac4adf8f7e0045cbddec8a31dc5c8b68eb4e7b0d3bd1f0661f26416
+DIST diffoscope-222.tar.gz 3145249 BLAKE2B ae91a16b4c21754d4c677922fed0a2f6102ba1ee370eac42a4008fcd0898adc7b1e86a900476f08eae8705353f05837daf4fcc4026d5beb27ab982b72a0e12d7 SHA512 b4f2e17fbb755517d922dfcbc0ae57544a89600338bed7d98d59ab024ddc13bcedcddfa6ee808530e163b3f6c3cf627b159b9d0a011765d03a9268839226590f
EBUILD diffoscope-219.ebuild 3324 BLAKE2B c9c95194b8d7d758834d27a1883bc1a884f6e3670ac81757bc251448e27afa437a4434966eb1cc5f79c026559241978eb913be3ec70b42f86dcba701a968db92 SHA512 5f53cf29280155a033b5aaf64512bd006fb1be72c6f8af2a1e0fc8669d1ac6f05441152fa66c41fbefa6ec74a31c2b1dbc11f08f27ca39f30e43cbc8c991b45e
EBUILD diffoscope-221.ebuild 3333 BLAKE2B dbbd07f3ba1ed69c7a71444b046c190182a522415def1dfae5f8e4cf22a25bb93d19fc6e61b43e1da9cf95270de7e85ecc66c258635a7d03a81ee7709cf9b657 SHA512 857ddab39cf606bce9f2339986d1b55dfcccee9d774deb469a9c2a169f3799851457611e0250a5d0c3a4d58d7e477a86744568e9d8f15bc8f223810837b38f17
+EBUILD diffoscope-222.ebuild 3333 BLAKE2B dbbd07f3ba1ed69c7a71444b046c190182a522415def1dfae5f8e4cf22a25bb93d19fc6e61b43e1da9cf95270de7e85ecc66c258635a7d03a81ee7709cf9b657 SHA512 857ddab39cf606bce9f2339986d1b55dfcccee9d774deb469a9c2a169f3799851457611e0250a5d0c3a4d58d7e477a86744568e9d8f15bc8f223810837b38f17
MISC metadata.xml 2078 BLAKE2B 3bb126836e45e8d4e5b6170a12219ec9cceb1a12dca4658211b1971cb16fa5593622642ade363904cf24df16de0749b957d0fc03838d2a9a004484d0b551c886 SHA512 382cefe0478282000b74e404cdd9d636a0323fceb55b97fd8545190628c319e0c5e213c7d082198e4b8b1fc693a52ce85c52b3ad831778e6fadbe6ba401782f5
diff --git a/dev-util/diffoscope/diffoscope-222.ebuild b/dev-util/diffoscope/diffoscope-222.ebuild
new file mode 100644
index 000000000000..bd5c0dd544f8
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-222.ebuild
@@ -0,0 +1,109 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+)
+
+distutils_enable_tests pytest