summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 05:44:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 05:44:58 +0000
commitcc4bdc5d184af171efd67a1b32de966071ee18d3 (patch)
tree99813a24b6b194fb3987dff98bcc0bbbf8eda9de /dev-util/diffoscope
parentc641f12d6bd92a8ea812f9b0e68a9a525a9c9ecc (diff)
gentoo auto-resync : 02:02:2024 - 05:44:58
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-255.ebuild124
2 files changed, 126 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 189d7c3392bb..b72acdeb0e40 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-247.tar.bz2 3091118 BLAKE2B cb41b98d439c123b5ee5f458d635f08afebde1dad724f53a8227826a509bca5e94204855fcd4f220567552abc0a3ea93e1c4a6e16dea0ed32ce7587c15d4976c SHA512 ceaa55512373e9283e6a18a9c5c814cd5b3ee8a9e9721f69b924ee55644640ea28302029232a310fca4d92e53fb37886d3d5ce2c6b577742261c86df24f52740
DIST diffoscope-253.tar.bz2 3102408 BLAKE2B 11743d3c6821c0ce2c78857152ab562780e39d6a4fc6e62da7a59652ff015c1ad643eaac2a2df0784419545045ef8854178377fd9f570ecd00d4059db2afd4c4 SHA512 e0516f5f0f20e4322f3525f5d00ee9b9029695fb94732c4c610ee09af5b6a9824789e99fe42611e807f11c284655bd9a872c4292e48a2237b400beb12575e950
+DIST diffoscope-255.tar.bz2 3108183 BLAKE2B ff212404e7855459ead91844f3c4d6d09dc3f52342c043c3834b9a8d7fd566692efb2e8541681c5cc53a3a71ccdab304ca8c0361cc094533e1d4f5cc01b3e24c SHA512 b5e419c535fc5d974c1f0d5d57e25949ce5e537b5d2717856cfaecb3cae3b873d9df1121c967f7bda1220c032ef509c46c39c471477179cea22c8ccc850afd42
EBUILD diffoscope-247.ebuild 4043 BLAKE2B 511752eff66f2ab826c63ff90f43643a804ba98eb865ec401f20bb12da9212fa17a3f5674a279be3e32cbbb72fb39a585d81ebd1824df859e613ea4dfd0eb09f SHA512 7218505a6938db6fcdaa7f7df7b756932f95d5d3b6065dd702af3b1c84c8267b5afb672e666309c5d3a08ebc8f66170102f62fbf6892b54388ce71963bd98409
EBUILD diffoscope-253-r1.ebuild 3682 BLAKE2B 9416955c1c9414ea2bcfb9ca5138638a3963dc71ec5443d6d993e3d132a566f62e613dd6dea2e38f26b3af6a176d620da2fabbe2159a8f979d2f8d91ae49332f SHA512 6a1cf8404cb306e7ddba0d19e591f62b622e616118f60285612a75991df02270d772eb647d1649f720da5c709312a4c18ad1eb86d9941c7f8512339fba7904d4
+EBUILD diffoscope-255.ebuild 3682 BLAKE2B 9416955c1c9414ea2bcfb9ca5138638a3963dc71ec5443d6d993e3d132a566f62e613dd6dea2e38f26b3af6a176d620da2fabbe2159a8f979d2f8d91ae49332f SHA512 6a1cf8404cb306e7ddba0d19e591f62b622e616118f60285612a75991df02270d772eb647d1649f720da5c709312a4c18ad1eb86d9941c7f8512339fba7904d4
MISC metadata.xml 2086 BLAKE2B b05c2c3c425a990f64aea25e9dda3e1afb410068d90e034d5d9df7c76363613d309f8bc57c70284f2e607a3e2096a0132724dddba8df487bda3046d8ed7aefa1 SHA512 8c86ddad7fda722956931d73a6f5dfa8e43c25623edb3b20bf3e68765b04ed4d20ba31b68315812978a9546b3c678597fd41132a4a6ad4658ba9fa5f79cfc90d
diff --git a/dev-util/diffoscope/diffoscope-255.ebuild b/dev-util/diffoscope/diffoscope-255.ebuild
new file mode 100644
index 000000000000..7db31ced97d2
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-255.ebuild
@@ -0,0 +1,124 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+# We could use pypi, but upstream provide distribution tarballs, so let's use those.
+# TODO: verify-sig
+SRC_URI="https://diffoscope.org/archive/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ sys-apps/file[python,${PYTHON_USEDEP}]
+ )
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-alternatives/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/pypdf[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( virtual/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="
+ test? (
+ app-arch/p7zip
+ app-text/docx2txt
+ app-text/html2text
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+ tests/comparators/test_gif.py::test_has_visuals
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+
+ # Fails on ZFS
+ tests/test_main.py::test_non_unicode_filename
+
+ # Fails on (unreleased) LLVM 16 with minor difference
+ #tests/comparators/test_macho.py::test_llvm_diff
+ #tests/comparators/test_elf.py::test_libmix_differences
+)
+
+distutils_enable_tests pytest