summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-util/diffoscope
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-177.ebuild28
2 files changed, 27 insertions, 3 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 179a2e12a137..a134b3d91964 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,3 +1,3 @@
DIST diffoscope-177.tar.gz 1590984 BLAKE2B 94daf9528c8fd0ad6ed89bdbee7b21352bf33dcef2ae7e526ea3b1036d92b6fecefcb0da46b7eedf7af1c8bd7995e73b8f0a5104c02f4db534f7bcc465c803aa SHA512 674a5cc364927437a79420b0965eb6958bd09df58a1238ea4d953bb2bc0fbdde75e42817370dd3cdab0bcc59551e1cff70db72298087af551d5dfaee57995811
-EBUILD diffoscope-177.ebuild 2583 BLAKE2B d1e590de5e1a9dcc0091863a74c983fa1bcad740fdf685c41c1f7f348c4f7fe614741365119eb1f2ebf60728c8ae108b22fd9a31e70aa0b35102ff1c222c63c3 SHA512 ea98891d82ffbc6ec9b1d3e992b5b1306cf23c300d85f8df56d265a1868d2f67c8f38b2db31e49e470fd852e501f5db9718dd9b1690ad582d88e5a8b1c0e0122
+EBUILD diffoscope-177.ebuild 3323 BLAKE2B acb100745327084b7476a4bc7f3df3d056974106f3c4b8c3ff1ec85e0e204df3ff43b892e8206424bc908b149130b7a6e40f828e885539f59c941d9a2f3bb907 SHA512 34a3dea18d4534232cea448f8565b4aae038f57bbfcf1b29bffd634dc12c5c15b1fd6b2a66959f57d7087984dd8dcab48b8f52cc5c54796a6fe606979db8e7cb
MISC metadata.xml 2137 BLAKE2B 70393ec4166e001aaeeb4c10958693ff090b04e7e5bf7eb760746dc4920e0554724f61e1a073f008660789438bec33378796ebc117c1cedcac5116b0b1d32142 SHA512 a1f5648c7593f16db4df87b750360034647704b1809ed52d585d49b5769ee8e190ff853941d2739da7c5f514ef02442b3b3ebf55fb21541e7bc551c720a305d0
diff --git a/dev-util/diffoscope/diffoscope-177.ebuild b/dev-util/diffoscope/diffoscope-177.ebuild
index 9ae8834c67c7..6b1e9ecce520 100644
--- a/dev-util/diffoscope/diffoscope-177.ebuild
+++ b/dev-util/diffoscope/diffoscope-177.ebuild
@@ -19,9 +19,20 @@ KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
find gettext gif gpg gzip haskell hdf5 hex imagemagick iso java llvm
mono opendocument pascal pdf postscript R rpm sqlite squashfs
-ssh tar tcpdump xz zip zstd"
+ssh tar test tcpdump xz zip zstd"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ )
+"
RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
dev-python/libarchive-c[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
@@ -84,6 +95,19 @@ python_test() {
# needs triage
tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
)
epytest ${exclude[@]/#/--deselect }
}