summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-01 22:03:23 +0100
commit590b9b7b03bf4651e099949e318755af7cfa81b8 (patch)
tree54c184b7d26c25f1922bfeaf19a1dd45a2e3b1eb /dev-util/diffoscope
parentf4fc10428424904caf2035cffc442195cb088b2c (diff)
gentoo resync : 01.08.2021
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-179.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index a7acd951ef59..bf85bc8be3ac 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-177.tar.gz 1590984 BLAKE2B 94daf9528c8fd0ad6ed89bdbee7b21352bf33dcef2ae7e526ea3b1036d92b6fecefcb0da46b7eedf7af1c8bd7995e73b8f0a5104c02f4db534f7bcc465c803aa SHA512 674a5cc364927437a79420b0965eb6958bd09df58a1238ea4d953bb2bc0fbdde75e42817370dd3cdab0bcc59551e1cff70db72298087af551d5dfaee57995811
DIST diffoscope-178.tar.gz 1600094 BLAKE2B b40e45748be56e49736a826decfb3a8c3ebd91983755719f2665733ceb6ec4e860265c33b5a3c15bc501abe4efdbecbdf177431bbbc79f1ad758c7deef83e1ae SHA512 706c95f5c04cfe081fed7e3e5ed73579949c948b15eaf0f984fc7d406b74007859f7946c44e4ca13e1210b105ed65ea68fd1f03452a50f161ed27f996f4f2540
+DIST diffoscope-179.tar.gz 1600145 BLAKE2B 64b7db8ad53980b80b3c563797736032a235d82b57dfb31496cfbd19978734759919482855ac7dadb62573f950294f02987fd9525b00886e56060450df390915 SHA512 7c3a73097bda2fd55414e52f557707afd08728c73305b55dc9482aff092a65c9bef33913c5e715ff6257aec6cc67095abfec3e8e23f002d43bf9e77e0d565154
EBUILD diffoscope-177-r1.ebuild 3325 BLAKE2B b11da425c3c3f5cbf6b6c654bc203c3d6bf56908e2dbdf35d9262a1e5b969655a62aab9aadf7501d6ffcf5c51a7c27a088dca858e81d6b041b72c52d53323da0 SHA512 137eee2580e2693c71fdc72c6cad6499c8be5bc5bb9c3eb302ae95578cbcd15b91a003357eca753392c69aa726797a8e550d7665811370b76fa54dc67bf3a55e
EBUILD diffoscope-178.ebuild 3340 BLAKE2B 6100a3b1d8a2f4ed70ead3f59a2734e6a9844cd85e68d2824e1f27e9d12bce575f2b4e46453469ad227d6f9e238b3b17e176b58e1cec6e9e8895e5f57315dc0a SHA512 28cc4833596e5a91ff194c62c194ce1d8773961d0b7498d29a932db19726e196cd3d429502c47bea46edea986784fc041f4f121ab3a4a853cd823e1949605df6
+EBUILD diffoscope-179.ebuild 3335 BLAKE2B 62131fbcc69564f8efa0c11a048a5464f0b6306d5c8b939a499f973d895926c92d2a1767d9f2e7c91ecc4fa3866b2103b2fc693195f1d1a472df00e087a233da SHA512 f86b53fd970f20e927f5b8a21434cbcbac4c22e7d622a7d5e2752ed059cfb10ecfe4ce299dfab2b329eae711d978b1ba5937f0e9a555b7944f51660179e2abc0
MISC metadata.xml 2077 BLAKE2B 2f4d188accf1f75c139a388f564ef5130ea8e74e403072871e4b73b848eaf405076bae7190565f374c193cb4f3fd0be16e3c781ac73df1d1cfb36101142b59eb SHA512 683e181724871d636610c7cfa93c714ceddba7e95b80fda8837e04b396f63049307b23b0471cfc19c46de5bd8b6f7bc868412f8f1c817933ac9507e7280b2272
diff --git a/dev-util/diffoscope/diffoscope-179.ebuild b/dev-util/diffoscope/diffoscope-179.ebuild
new file mode 100644
index 000000000000..ee2bed80f614
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-179.ebuild
@@ -0,0 +1,113 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="ncurses"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ )
+"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local exclude=(
+ # test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+
+ # needs triage
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+ )
+ epytest ${exclude[@]/#/--deselect }
+}