summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 14:59:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 14:59:59 +0000
commit529abfa74a08ae5099db9780bcdf8250aa52ecb6 (patch)
tree2e2d1a9fd6e89b4872499afea3dc57490271e69c /dev-util/diffoscope
parente6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (diff)
gentoo auto-resync : 03:12:2022 - 14:59:58
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-228.ebuild120
2 files changed, 122 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index f9a55e99cf71..ef486bb589a7 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-223.tar.gz 3145330 BLAKE2B 47ebe733c6330c2c8a7a78dfaad4c364ac3570d5a691b889f3154dcc5f7bec7b97744f04433cf56544ca208233271bbbca8bb767ed43844786fca4e77505d95b SHA512 5f83177133fd4689a77fb08038222998f9597cd63b0f328d3ae55c2ef6f5136f55ab1f5841b70ce1f64a62d216e2332bb4cecb82a3edcc90a6a5841e95955d4c
DIST diffoscope-227.tar.gz 3163754 BLAKE2B 8a93b168e8ac404b6cfb08ebf9de5adf0288ae6e741653f8194a2d3d45e30b5826ca3d21a37b5db3867c73816e862f1d4593fe7a77487736f8a6e5f2b15057f2 SHA512 1e8a143006c4e734cf30d4110241ed164c3ee893801efa2a7b81a917146a0643dd8b38af0cac937847506a4338d59f4bb03211179742bb076fc4d4dd5f7cb585
+DIST diffoscope-228.tar.gz 3164190 BLAKE2B 21e75cb8e297540b149f22c52949d33a2e6ddd8c0fa8641e5d8b0c20045f1a7f6638b6b844631c2a5353cd23dc4d8447fadd9b8b3f5cd87fa33eb4b85abe3e2b SHA512 5ea3f0dfa17d2e17167241f9388a6fba919deec4c26a39e238fc282b0011f30e77b4daf27c0b076eadcc13ca51eb408eba983ea427adbaee3233db222b60948a
EBUILD diffoscope-223.ebuild 3444 BLAKE2B ace11e44d106488caa6e2e2014236e1d5889667c48348ef29b6b34b719f5b95392cc0f2aaf73ecf0a01085263e4dea21c3ba4280802abca4fe95ac2c2c018c17 SHA512 e9cb6a0ec3fe55146081dd3336409c49112b55dda2e7edb97c9c0b6269ca29f9706dbf9b1cc5061d4d0869f980824ea8ebe447e191d015510af58a50014f659b
EBUILD diffoscope-227.ebuild 3558 BLAKE2B 0b9aeb382a8bb6821e7b0e6a582fbc85564ef64e9d4931322e339c104d92a08d054958b0c604fc5688cb2ec6e5a1639aaf7700f97a203f12f17951f48cd661b0 SHA512 3ebd890410be2c423fc465f3cb149f98a4690ecaa5683b6c1dcf91a5c3c8423d5515ab516652d2c6e8a7ba2b8407d7830550244ded1fc5fc4d2cd91efb7a683e
+EBUILD diffoscope-228.ebuild 3558 BLAKE2B 0b9aeb382a8bb6821e7b0e6a582fbc85564ef64e9d4931322e339c104d92a08d054958b0c604fc5688cb2ec6e5a1639aaf7700f97a203f12f17951f48cd661b0 SHA512 3ebd890410be2c423fc465f3cb149f98a4690ecaa5683b6c1dcf91a5c3c8423d5515ab516652d2c6e8a7ba2b8407d7830550244ded1fc5fc4d2cd91efb7a683e
MISC metadata.xml 2078 BLAKE2B 3bb126836e45e8d4e5b6170a12219ec9cceb1a12dca4658211b1971cb16fa5593622642ade363904cf24df16de0749b957d0fc03838d2a9a004484d0b551c886 SHA512 382cefe0478282000b74e404cdd9d636a0323fceb55b97fd8545190628c319e0c5e213c7d082198e4b8b1fc693a52ce85c52b3ad831778e6fadbe6ba401782f5
diff --git a/dev-util/diffoscope/diffoscope-228.ebuild b/dev-util/diffoscope/diffoscope-228.ebuild
new file mode 100644
index 000000000000..e7f6e7cb72c0
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-228.ebuild
@@ -0,0 +1,120 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence of filemagic's magic.py breaks imports
+# of dev-python/python-magic: bug #716482
+RDEPEND+=" !dev-python/filemagic"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="
+ test? (
+ app-text/docx2txt
+ app-text/html2text
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+ tests/comparators/test_gif.py::test_has_visuals
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+
+ # Fails on ZFS
+ tests/test_main.py::test_non_unicode_filename
+
+ # Fails on (unreleased) LLVM 16 with minor difference
+ tests/comparators/test_macho.py::test_llvm_diff
+)
+
+distutils_enable_tests pytest