summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 14:05:23 +0100
commit05b8b0e0af1d72e51a3ee61522941bf7605cd01c (patch)
tree43b0410e62aba677b4b256bc3ffe3fd333d28dbe /dev-util/diffoscope
parent90c88731bd036e5698b281fbc0a5f3aa4c9983ac (diff)
gentoo resync : 04.07.2020
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-150.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index 1a22aa6eef45..0054f2dc3c70 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,3 +1,5 @@
DIST diffoscope-149.tar.gz 1570458 BLAKE2B 8182822f01805277937bf6993094a2ad2e32fde47a67a01a071691487582c22f9be9e299701ad2feda85ce79d5952747348e3180b22e60878d01f28f6e8a9ff5 SHA512 557f0edcd5620a097668108a223f3f58338890eaeb096982c398f1182e26219027c4d62dab688a19743be1167d0affa9dbd6b7b7440fcf86a7f55ade7e3be288
+DIST diffoscope-150.tar.gz 1570701 BLAKE2B 74b146ca6940313817025ba1285ae529c17da82d3cb13dae1b3550cf900d626e774eda3b993f930cf2cc7cc72e0f47830c02ec8ad0d5eff18cefb259757663d3 SHA512 ae2932bcb44078c1ab932512251dfbdfb4d3df0113388b22c5d77e74b74f7efc0f9b4c0bffd6d79422d89d3be6bfe07f9aad337365e5ee704f2710de36cbf4b7
EBUILD diffoscope-149.ebuild 2161 BLAKE2B 9ef4a812c5fec5a923b0b796814052c00842cd36a447832fe65aed32c341454538ddccce2baac0b038d8bf02cbed98a2023eeba33e8a7868f34a882331098c34 SHA512 e508fee8307b2e634ec33877124156fcb8afd43307747b1f61e18ecfeaac00c1140c1906ef87015f3b76f70ac5679c28fed47539e52ce0adc29c6257ad6deacb
+EBUILD diffoscope-150.ebuild 2161 BLAKE2B 9ef4a812c5fec5a923b0b796814052c00842cd36a447832fe65aed32c341454538ddccce2baac0b038d8bf02cbed98a2023eeba33e8a7868f34a882331098c34 SHA512 e508fee8307b2e634ec33877124156fcb8afd43307747b1f61e18ecfeaac00c1140c1906ef87015f3b76f70ac5679c28fed47539e52ce0adc29c6257ad6deacb
MISC metadata.xml 2137 BLAKE2B 6ff55f85ebf3f769c10c3e17a69900918abe142e491b7b8460bed8fe6a036763a743324bf1a10e7a3772761b38c9632ff1352e9c6677ef691f81acc29dc321e9 SHA512 e782e12dc91d86612768a2e0c498f54a9728691a76008ee1e6cdbc4d8719c2593344f6c37786982abb0de7b85d743d7614652a2e8c9cd9fef053c3a32e1e484c
diff --git a/dev-util/diffoscope/diffoscope-150.ebuild b/dev-util/diffoscope/diffoscope-150.ebuild
new file mode 100644
index 000000000000..63058ee2f20a
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-150.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg gzip haskell hdf5 hex imagemagick iso java llvm
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar tcpdump xz zip zstd"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ gzip? ( app-arch/gzip )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( virtual/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ xz? ( app-arch/xz-utils )
+ zip? ( app-arch/unzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"