summaryrefslogtreecommitdiff
path: root/dev-util/diffoscope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-04 02:04:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-04 02:04:17 +0100
commit00d9a8fc3e9e5bafeff6747e978c1685b384e587 (patch)
tree43c6db3767706ffe339a7040cb0a5dea8bd1ef26 /dev-util/diffoscope
parent799073eb168d35819904276f6c912be4ac76166a (diff)
gentoo auto-resync : 04:08:2022 - 02:04:17
Diffstat (limited to 'dev-util/diffoscope')
-rw-r--r--dev-util/diffoscope/Manifest2
-rw-r--r--dev-util/diffoscope/diffoscope-220.ebuild109
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-util/diffoscope/Manifest b/dev-util/diffoscope/Manifest
index aa9073837242..7d44a9daf1fe 100644
--- a/dev-util/diffoscope/Manifest
+++ b/dev-util/diffoscope/Manifest
@@ -1,5 +1,7 @@
DIST diffoscope-214.tar.gz 2710707 BLAKE2B 6acd7fa9c69ad831c6d362b805c2094b2f55d57fa87f69e9e153a99a71c90a67884796696df0d24d6b3c94c0b9a41736292d44208f4d8de4262eaa5f2eec6c90 SHA512 67a9b68ce5f7934747e30e41506d7e30f018673314b777ab86af89e3dd56212c442abe6e246741f7b842b5c58f14006442167cf9089823ba4ef1ba07e78eaaa7
DIST diffoscope-219.tar.gz 2711533 BLAKE2B 1b244a36ca2622244fb1f11f8fc895680bd1d77b544421e5e2c3662294fdf8e7efe3b67e370a83089c180f3c8563562847cc8b09bec85426e1b05f340575b724 SHA512 615b82cbd2b1a8bcdfae4274c051e4be52fb8ea90c5e56b041dd1d8c520c759d09cd4c080b31154257828316f7b4c0ac79cf0b1e09d762271ce01ffde353ee7a
+DIST diffoscope-220.tar.gz 3145338 BLAKE2B ecc679184e7138180c354b6ad9b4ec33cc27f818228da7587f4be3f5704ed788426175692f56e52fc5889690b1b8ee75690ddbf14113ad7c5336b0ceee6f9ac2 SHA512 fd7a30f30b7f67ae92650afb42684f71de3bc9e34c93534830445a608f772290865e0d494492563641dc4721433705be3f642c0085846dfaced3fe4dce9c534b
EBUILD diffoscope-214.ebuild 3296 BLAKE2B 0d6f5c5ffa8be6470d622af2cf72181d283ece6bad089459d6ca12847df804b1174e104d74d39c447e632c6be4c182b56de8fb484c41e6afad9cbd0991ea98b9 SHA512 b8d9e8d6fdc0ab77d79d5f78a3718a6cf90c23afda16a37cad7fb70209f936eca1236f7b3058c89d14e36c1ffe645a81cc08963b2c25ec4c78b39320af30db37
EBUILD diffoscope-219.ebuild 3324 BLAKE2B c9c95194b8d7d758834d27a1883bc1a884f6e3670ac81757bc251448e27afa437a4434966eb1cc5f79c026559241978eb913be3ec70b42f86dcba701a968db92 SHA512 5f53cf29280155a033b5aaf64512bd006fb1be72c6f8af2a1e0fc8669d1ac6f05441152fa66c41fbefa6ec74a31c2b1dbc11f08f27ca39f30e43cbc8c991b45e
+EBUILD diffoscope-220.ebuild 3326 BLAKE2B ef5314ab8e78b5e93dbdd56dae8bb48df59eeefc8d42d918c29ff87189ee5fe2df07879b2abe04893557265417050c39e68b265fd9c21ecc7e546ab4b15fe21b SHA512 3a73dec69cdef67b5cf7439f5263158c37e5a868376c185da25a447305a25da3b992ad2c0f81469ca5e4a182f85c709a5fd899a84162dd55e7154e948d15ee84
MISC metadata.xml 2078 BLAKE2B 3bb126836e45e8d4e5b6170a12219ec9cceb1a12dca4658211b1971cb16fa5593622642ade363904cf24df16de0749b957d0fc03838d2a9a004484d0b551c886 SHA512 382cefe0478282000b74e404cdd9d636a0323fceb55b97fd8545190628c319e0c5e213c7d082198e4b8b1fc693a52ce85c52b3ad831778e6fadbe6ba401782f5
diff --git a/dev-util/diffoscope/diffoscope-220.ebuild b/dev-util/diffoscope/diffoscope-220.ebuild
new file mode 100644
index 000000000000..177ba73b1c19
--- /dev/null
+++ b/dev-util/diffoscope/diffoscope-220.ebuild
@@ -0,0 +1,109 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg haskell hdf5 hex imagemagick iso java llvm lzma
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar test tcpdump zip zlib zstd"
+
+RESTRICT="!test? ( test )"
+
+# pull in optional tools for tests:
+# img2txt: bug #797688
+# docx2txt: bug #797688
+BDEPEND="test? (
+ app-text/docx2txt
+ media-libs/libcaca
+ virtual/imagemagick-tools[jpeg]
+ )"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/libarchive-c[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tlsh[${PYTHON_USEDEP}]
+ acl? ( sys-apps/acl )
+ binutils? ( sys-devel/binutils )
+ bzip2? ( app-arch/bzip2 )
+ libcaca? ( media-libs/libcaca )
+ colord? ( x11-misc/colord )
+ cpio? ( app-arch/cpio )
+ diff? ( sys-apps/diffutils )
+ docx? ( app-text/docx2txt )
+ dtc? ( sys-apps/dtc )
+ e2fsprogs? ( sys-fs/e2fsprogs )
+ file? ( sys-apps/file )
+ find? ( sys-apps/findutils )
+ gettext? ( sys-devel/gettext )
+ gif? ( media-libs/giflib )
+ gpg? ( app-crypt/gnupg )
+ haskell? ( dev-lang/ghc )
+ hdf5? ( sci-libs/hdf5 )
+ hex? ( app-editors/vim-core )
+ imagemagick? ( media-gfx/imagemagick )
+ iso? ( app-cdr/cdrtools )
+ java? ( virtual/jdk )
+ llvm? ( sys-devel/llvm )
+ lzma? ( app-arch/xz-utils )
+ mono? ( dev-lang/mono )
+ opendocument? ( app-text/odt2txt )
+ pascal? ( dev-lang/fpc )
+ pdf? (
+ app-text/pdftk
+ app-text/poppler
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ )
+ postscript? ( app-text/ghostscript-gpl )
+ R? ( dev-lang/R )
+ rpm? ( app-arch/rpm )
+ sqlite? ( dev-db/sqlite:3 )
+ squashfs? ( sys-fs/squashfs-tools )
+ ssh? ( net-misc/openssh )
+ tar? ( app-arch/tar )
+ tcpdump? ( net-analyzer/tcpdump )
+ zip? ( app-arch/unzip )
+ zlib? ( app-arch/gzip )
+ zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"
+
+EPYTEST_DESELECT=(
+ # Test seems to use different tarball
+ tests/test_presenters.py::test_text_proper_indentation
+
+ # Needs triage
+ tests/comparators/test_binary.py::test_with_compare_details_and_tool_not_found
+ tests/comparators/test_rlib.py::test_item3_deflate_llvm_bitcode
+
+ # img2txt based failures, bug #797688
+ tests/comparators/test_ico_image.py::test_diff
+ tests/comparators/test_ico_image.py::test_diff_meta
+ tests/comparators/test_ico_image.py::test_diff_meta2
+ tests/comparators/test_ico_image.py::test_has_visuals
+ tests/comparators/test_jpeg_image.py::test_diff
+ tests/comparators/test_jpeg_image.py::test_compare_non_existing
+ tests/comparators/test_jpeg_image.py::test_diff_meta
+ tests/comparators/test_jpeg_image.py::test_has_visuals
+
+ # docx2txt based falures, bug #797688
+ tests/comparators/test_docx.py::test_diff
+
+ # Formatting
+ tests/test_source.py::test_code_is_black_clean
+)
+
+distutils_enable_tests pytest