summaryrefslogtreecommitdiff
path: root/dev-util/diffball
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-util/diffball
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-util/diffball')
-rw-r--r--dev-util/diffball/Manifest5
-rw-r--r--dev-util/diffball/diffball-1.0.1-r1.ebuild38
-rw-r--r--dev-util/diffball/metadata.xml7
3 files changed, 45 insertions, 5 deletions
diff --git a/dev-util/diffball/Manifest b/dev-util/diffball/Manifest
index c01fcffdd835..95a30ed84ab6 100644
--- a/dev-util/diffball/Manifest
+++ b/dev-util/diffball/Manifest
@@ -1,3 +1,6 @@
+DIST diffball-1.0.1-bug_543310_stack_buffer_overflows.patch 2945 BLAKE2B 17aa01d64464edccc490e7714dc9db8767d19b0c8b6d14223359d266d38e47aae822454aa14446c038b2b3477a4d8a8db228be7e28666528883ebf02ac2cb65b SHA512 be9a44cd9abfb41f32683d0363375902477f739f9c0dd23b30cfcd9fc6fced61111a2b101cb46db2d6320b4d70ed04627a1c178d44f23530f248bcb87e6efd32
DIST diffball-1.0.1.tar.bz2 387787 BLAKE2B e46dbf32b2ec9bece106ca90a6ae46bdfde8b83a5fd41e67f15c4bd25d7015327b4738ce3bfba71c92fd2baa94a5d3bc507dd0fad2b3451447a39a7fe058002e SHA512 1e01fff8bf7d993c828f195d974b7df1cd4fb056e9a51f9533bc8e01666a55e0d9467c799a005f58d7b4369bbf88fc9b716d0fb68ead6171d349e3c874bddb8c
+DIST diffball-1.0.1.tar.gz 86387 BLAKE2B 1e2c6d522b00a643666e88d19d2d6986ce02c7835378dfc9799e43fa291683bf08e129546a85c332b04ab549788ae4ac3b4d57fd6140a29a9556bece4293cbf9 SHA512 3344f03a65e2b44615eaf9210d26a4438712684c438fcea9caabe89688fe3b3d5436703f0ed63412a18a63acb49ca0dacff190fa002ea76b346bbccba3388ee4
+EBUILD diffball-1.0.1-r1.ebuild 1013 BLAKE2B ea7a6f97ae95ce9568c172b865a1fd259a0b4f8014e20754c2f0512084791660f1a4fadba9c2f491dcdc332de90c903e2338551939dfbe62f9e3400d42bc2f81 SHA512 b206297573957da74b7d50cbcf9b410fd6005ae26f77852a44c75262b732e247e1fde141be9dabded566bfdecf0d36e04390461a6ed4d673909e87478d7b50c8
EBUILD diffball-1.0.1.ebuild 850 BLAKE2B 02535a55320b2cb6831801d8bc4d12675659d10db9909984b88ab5cf605c9d4735ce3198e5579a17cb6cddc444f331a9e230d4ec59d9468b72999c983296295f SHA512 0df7a66f7f67f5d7115c272787f73322767434a4ccbd47cef8e8519acc92c476c23fa98f5c74a11d10142435754cf12daa35ab2ac41a9136f09c1d49e12a5a6f
-MISC metadata.xml 397 BLAKE2B 08a0d58404fdad1f2d187d5f6f51a061c5b1b24e83ffc3b59b54b223305c8da2f9082d8c961d6bb4ad13f2bb659cf265677d6d1fb7b70fd560add8e64d011f34 SHA512 4375382936f9f3f05349b4d648134251ed463ec7f74d3af2c48b1045999e1c69f9131853efb613d171b17e3ac8d7b17ec56a8088518bd6ef1aa442bd7f287bb8
+MISC metadata.xml 325 BLAKE2B d2fe2133512a06976ca331af0d318fbe888fac115af9e2635a3f682eb1ffcc0c9088e87437c39803cfa5183aaa2a5df091113efa6f7259e91960340ce095717d SHA512 8c9cb7fc1861a080e525eed799e80650b9c8ec4b0416959c9b754099cec1c26651beb5364992b8a3c80ed3285bff74f0a0b72a4032e3b243cab0191d8fd8856a
diff --git a/dev-util/diffball/diffball-1.0.1-r1.ebuild b/dev-util/diffball/diffball-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..9bff04668006
--- /dev/null
+++ b/dev-util/diffball/diffball-1.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="https://github.com/zmedico/diffball"
+SRC_URI="https://github.com/zmedico/diffball/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/zmedico/diffball/pull/1.patch -> ${P}-bug_543310_stack_buffer_overflows.patch"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=app-arch/bzip2-1.0.2
+ app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# Invalid RESTRICT for source package. Investigate.
+RESTRICT="strip"
+
+PATCHES=("${DISTDIR}/${P}-bug_543310_stack_buffer_overflows.patch")
+
+src_prepare() {
+ # fix bug 548316 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug asserts)
+}
diff --git a/dev-util/diffball/metadata.xml b/dev-util/diffball/metadata.xml
index eac20fbfab6a..3f9423fb713a 100644
--- a/dev-util/diffball/metadata.xml
+++ b/dev-util/diffball/metadata.xml
@@ -2,11 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>rafaelmartins@gentoo.org</email>
- <name>Rafael G. Martins</name>
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
</maintainer>
<upstream>
- <remote-id type="github">rafaelmartins/diffball</remote-id>
- <remote-id type="google-code">diffball</remote-id>
+ <remote-id type="github">zmedico/diffball</remote-id>
</upstream>
</pkgmetadata>