summaryrefslogtreecommitdiff
path: root/dev-util/diffball
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/diffball
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/diffball')
-rw-r--r--dev-util/diffball/Manifest3
-rw-r--r--dev-util/diffball/diffball-1.0.1.ebuild34
-rw-r--r--dev-util/diffball/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/diffball/Manifest b/dev-util/diffball/Manifest
new file mode 100644
index 000000000000..168fc05530c4
--- /dev/null
+++ b/dev-util/diffball/Manifest
@@ -0,0 +1,3 @@
+DIST diffball-1.0.1.tar.bz2 387787 BLAKE2B e46dbf32b2ec9bece106ca90a6ae46bdfde8b83a5fd41e67f15c4bd25d7015327b4738ce3bfba71c92fd2baa94a5d3bc507dd0fad2b3451447a39a7fe058002e SHA512 1e01fff8bf7d993c828f195d974b7df1cd4fb056e9a51f9533bc8e01666a55e0d9467c799a005f58d7b4369bbf88fc9b716d0fb68ead6171d349e3c874bddb8c
+EBUILD diffball-1.0.1.ebuild 806 BLAKE2B ad4d0357693531577a5c9f6d0f6ca5582af0849bfe0686162de8cb8320b2cc370ef4c325a997a1e804bf6c3b3041e87627bce63e0b4e700b1c42d17a8d564342 SHA512 3c5be0e9608123c1bc5f1bc30b458f59c387e9661cfd27ff5935b6841888e6c94ac779792c206f2b659a1b0dd46fd1c7e40727b9e697fcc1cf1b80a2ea12348e
+MISC metadata.xml 335 BLAKE2B a5e825f2df16ec0a8abe5be5a5e00c986c204b0d46da6a61370f4379b88a181ae473502cb33db6817a05e5c436979f7c2ab30963ff7d85b3d6a7cd01789a4ab2 SHA512 873a67d443a91385a6b7891ee5a09aa3f99cf96410b9165330af17d63333beb72c0e614142274a80ac433089c28a233110b9a142ed3ef2fa269b9a2d2a524e34
diff --git a/dev-util/diffball/diffball-1.0.1.ebuild b/dev-util/diffball/diffball-1.0.1.ebuild
new file mode 100644
index 000000000000..0902b00c14f9
--- /dev/null
+++ b/dev-util/diffball/diffball-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="https://diffball.googlecode.com/"
+SRC_URI="https://diffball.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=app-arch/bzip2-1.0.2
+ app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# Invalid RESTRICT for source package. Investigate.
+RESTRICT="strip"
+
+src_prepare() {
+ # fix bug 548316 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
+}
+
+src_configure() {
+ econf $(use_enable debug asserts)
+}
diff --git a/dev-util/diffball/metadata.xml b/dev-util/diffball/metadata.xml
new file mode 100644
index 000000000000..70aa8c7d2862
--- /dev/null
+++ b/dev-util/diffball/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">diffball</remote-id>
+ </upstream>
+</pkgmetadata>