summaryrefslogtreecommitdiff
path: root/dev-util/devhelp/devhelp-40.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-util/devhelp/devhelp-40.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-util/devhelp/devhelp-40.1.ebuild')
-rw-r--r--dev-util/devhelp/devhelp-40.1.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/dev-util/devhelp/devhelp-40.1.ebuild b/dev-util/devhelp/devhelp-40.1.ebuild
deleted file mode 100644
index ef47f98c8097..000000000000
--- a/dev-util/devhelp/devhelp-40.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit gnome.org gnome2-utils meson python-single-r1 xdg
-
-DESCRIPTION="An API documentation browser for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp"
-
-LICENSE="GPL-3+ CC-BY-SA-4.0"
-SLOT="0/3-6" # subslot = 3-(libdevhelp-3 soname version)
-KEYWORDS="amd64 ~arm ~ppc64 ~sparc x86"
-IUSE="+gedit gtk-doc +introspection"
-REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
- >=dev-libs/glib-2.64:2
- >=x11-libs/gtk+-3.22:3[introspection?]
- >=net-libs/webkit-gtk-2.26:4[introspection?]
- >=gui-libs/amtk-5.0:5
- gnome-base/gsettings-desktop-schemas
- introspection? ( >=dev-libs/gobject-introspection-1.54:= )
-"
-RDEPEND="${DEPEND}
- gedit? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- app-editors/gedit[introspection(+),python,${PYTHON_SINGLE_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
- )
-"
-# libxml2 required for glib-compile-resources
-BDEPEND="
- ${PYTHON_DEPS}
- dev-libs/libxml2:2
- dev-util/glib-utils
- dev-util/itstool
- gtk-doc? (
- >=dev-util/gtk-doc-1.25
- app-text/docbook-xml-dtd:4.3
- )
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/40.0-optional-introspection.patch
-)
-
-pkg_setup() {
- use gedit && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local emesonargs=(
- -Dflatpak_build=false
- $(meson_use gtk-doc gtk_doc)
- $(meson_use introspection)
- -Dplugin_emacs=true
- $(meson_use gedit plugin_gedit)
- -Dplugin_vim=true
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- use gedit && python_optimize "${ED}"/usr/$(get_libdir)/gedit/plugins
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}