summaryrefslogtreecommitdiff
path: root/dev-util/devhelp/devhelp-3.30.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-util/devhelp/devhelp-3.30.1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-util/devhelp/devhelp-3.30.1.ebuild')
-rw-r--r--dev-util/devhelp/devhelp-3.30.1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-util/devhelp/devhelp-3.30.1.ebuild b/dev-util/devhelp/devhelp-3.30.1.ebuild
index e00885f4d8ee..014be70449d8 100644
--- a/dev-util/devhelp/devhelp-3.30.1.ebuild
+++ b/dev-util/devhelp/devhelp-3.30.1.ebuild
@@ -2,9 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-# gedit-3.8 is python3 only, this also per:
-# https://bugzilla.redhat.com/show_bug.cgi?id=979450
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit gnome.org gnome2-utils meson python-single-r1 xdg
@@ -28,8 +26,11 @@ COMMON_DEPEND="
RDEPEND="${COMMON_DEPEND}
gedit? (
${PYTHON_DEPS}
- app-editors/gedit[introspection,python,${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ app-editors/gedit[introspection,python,${PYTHON_SINGLE_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
"
# libxml2 required for glib-compile-resources
DEPEND="${COMMON_DEPEND}